Bug 504674 - Satellite Proxy, cmd line installer rhncfg error
Satellite Proxy, cmd line installer rhncfg error
Status: CLOSED DUPLICATE of bug 503584
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
na
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-06-08 14:51 EDT by wes hayutin
Modified: 2009-08-09 14:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 16:00:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-08 14:51:30 EDT
Description of problem:

6/5 rhel 5 cmd line proxy installer...

got a rhncfg error, the install completes, tested rhncfg and it *seems* ok.
writting this up so dev can take a look.

Using server name grandprix.rhndev.redhat.com
Pushing to channel rhn_proxy_config_1000010064:
XML-RPC call error: <ProtocolError for grandprix.rhndev.redhat.com /CONFIG-MANAGEMENT-TOOL: 500 Internal Server Error>
Enabling Spacewalk Proxy.
Shutting down rhn-proxy...


[root@fjs-0-12 ~]# rhncfg-manager list-channels
Available config channels:
  rhn_proxy_config_1000010064
[root@fjs-0-12 ~]#
Comment 1 Clifford Perry 2009-06-09 10:07:08 EDT
XML-RPC call error: <ProtocolError for grandprix.rhndev.redhat.com
/CONFIG-MANAGEMENT-TOOL: 500 Internal Server Error>


Your server will have generated a server side error/traceback. Can you attach this to this bug. 

Cliff
Comment 2 Miroslav Suchý 2009-06-09 15:55:50 EDT
I tried it and it works without problem - for me. Can you elaborate what caused your error?

Create and populate configuration channel rhn_proxy_config_1000010042? [Y/n]:
Using server name xen30.englab.brq.redhat.com
Red Hat Network username: admin
Password:
Creating config channel rhn_proxy_config_1000010042
Config channel rhn_proxy_config_1000010042 created
Using server name xen30.englab.brq.redhat.com
Pushing to channel rhn_proxy_config_1000010042:
Local file /etc/httpd/conf.d/ssl.conf -> remote file /etc/httpd/conf.d/ssl.conf
Local file /etc/rhn/rhn.conf -> remote file /etc/rhn/rhn.conf
Local file /etc/rhn/cluster.ini -> remote file /etc/rhn/cluster.ini
Local file /etc/squid/squid.conf -> remote file /etc/squid/squid.conf
Local file /etc/httpd/conf.d/cobbler-proxy.conf -> remote file /etc/httpd/conf.d/cobbler-proxy.conf
Local file /etc/httpd/conf/httpd.conf -> remote file /etc/httpd/conf/httpd.conf
Local file /etc/httpd/conf.d/rhn_proxy.conf -> remote file /etc/httpd/conf.d/rhn_proxy.conf
Local file /etc/httpd/conf.d/proxy_broker.conf -> remote file /etc/httpd/conf.d/proxy_broker.conf
Local file /etc/httpd/conf.d/proxy_redirect.conf -> remote file /etc/httpd/conf.d/proxy_redirect.conf
Local file /etc/jabberd/c2s.xml -> remote file /etc/jabberd/c2s.xml
Local file /etc/jabberd/sm.xml -> remote file /etc/jabberd/sm.xml
Enabling Spacewalk Proxy.
Comment 3 Clifford Perry 2009-06-09 16:00:47 EDT
Looking at httpd logs on system:

10.10.76.139 - - [08/Jun/2009:14:09:54 -0400] "POST /CONFIG-MANAGEMENT-TOOL HTTP/1.1" 500 9 "-" "rhn.rpclib.py/$Revision: 136589 $"


[root@grandprix httpd]# grep "Mon Jun 08 14:09" error_log
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonHeaderParserHandler server.apacheServer::HeaderParserHandler: Traceback (most recent call last):
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonHeaderParserHandler server.apacheServer::HeaderParserHandler:   File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 287, in HandlerDispatch\n    log=debug)
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonHeaderParserHandler server.apacheServer::HeaderParserHandler:   File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 461, in import_module\n    f, p, d = imp.find_module(parts[i], path)
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonHeaderParserHandler server.apacheServer::HeaderParserHandler: ImportError: No module named apacheServer
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonLogHandler server.apacheServer::LogHandler: Traceback (most recent call last):
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonLogHandler server.apacheServer::LogHandler:   File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 287, in HandlerDispatch\n    log=debug)
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonLogHandler server.apacheServer::LogHandler:   File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 461, in import_module\n    f, p, d = imp.find_module(parts[i], path)
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonLogHandler server.apacheServer::LogHandler: ImportError: No module named apacheServer
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonCleanupHandler server.apacheServer::CleanupHandler: Traceback (most recent call last):
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonCleanupHandler server.apacheServer::CleanupHandler:   File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 287, in HandlerDispatch\n    log=debug)
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonCleanupHandler server.apacheServer::CleanupHandler:   File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 461, in import_module\n    f, p, d = imp.find_module(parts[i], path)
[Mon Jun 08 14:09:54 2009] [error] [client 10.10.76.139] PythonCleanupHandler server.apacheServer::CleanupHandler: ImportError: No module named apacheServer
[root@grandprix httpd]# 


The ISE was generated by bug 503584.

*** This bug has been marked as a duplicate of bug 503584 ***

Note You need to log in before you can comment on or make changes to this bug.