Bug 504698 - old xorg-x11-server-randr-source left installed after upgrade
old xorg-x11-server-randr-source left installed after upgrade
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.4
All Linux
low Severity urgent
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-08 16:37 EDT by Mark Gordon
Modified: 2013-07-28 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:42:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Gordon 2009-06-08 16:37:59 EDT
Description of problem:
The xorg-x11-server-randr-source package went away, which I understand was intentional, but since no package Obsoletes xorg-x11-server-randr-source, a previously installed xorg-x11-server-randr-source would remain in place.

Version-Release number of selected component (if applicable):
1.1.1-48.64.el5 is the latest build, and it's been broken since the change from 1.1.1-48.52.el5

How reproducible:
Completely, iff xorg-x11-server-randr-source is installed.

Steps to Reproduce:
1. Attempt to upgrade from xorg-x11-server-*-1.1.1-48.52.el5 to xorg-x11-server-*-1.1.1-48.64.el5
  
Actual results:
-randr-source gets left behind.  In theory, this doesn't break upgrades, but it does break subsequent downgrades.

Expected results:
-randr-source should get uninstalled automagically when the other xorg-x11-server packages are upgraded.

Additional info:
Comment 2 Adam Jackson 2009-06-24 14:36:03 EDT
Devel ack, trivial.
Comment 3 RHEL Product and Program Management 2009-06-24 14:53:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Adam Jackson 2009-06-29 15:38:20 EDT
1866469 build (dist-5E-qu-candidate, RHEL-5:xorg-x11-server-1_1_1-48_65_el5): open (hs20-bc2-5.build.redhat.com) -> closed

MODIFIED
Comment 6 Mark Gordon 2009-07-14 14:07:44 EDT
Tested updating to the new packages.  xorg-x11-server-randr-source now gets uninstalled automagically on upgrade of xorg-x11-server-Xorg.  I'm happy.
Comment 8 errata-xmlrpc 2009-09-02 07:42:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1373.html

Note You need to log in before you can comment on or make changes to this bug.