Bug 504718 - Google Earth,CoolIris, not working--- SELinux Denial
Google Earth,CoolIris, not working--- SELinux Denial
Status: CLOSED DUPLICATE of bug 491229
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-08 20:01 EDT by BlackHawkDown
Modified: 2009-09-04 11:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 11:44:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Bug Files (12.81 KB, text/plain)
2009-06-08 20:01 EDT, BlackHawkDown
no flags Details

  None (edit)
Description BlackHawkDown 2009-06-08 20:01:18 EDT
Created attachment 346944 [details]
The Bug Files

Google earth will install but after installation it will not run.Same goes with cooliris, and something else with a cache.
Comment 1 Daniel Walsh 2009-06-09 07:31:56 EDT
Did you try executing the chcon commands suggested in the setroubleshoot.

The problem is the libraries are built incorrectly at google.  

Open a bug report with them and suggest the build their libraries with the -PIC flag so SELinux will not see their code as doing something wrong.

You can attach this link.

http://people.redhat.com/~drepper/selinux-mem.html

This explains the memory checks.

You can turn off these checks by executing

# setsebool -P allow_execmod 1



As far as the other AVC's you need to update to the latest selinux-policy-targeted


yum -y upgrade selinux-policy-targeted


selinux-policy-3.5.13-63.fc10
Comment 2 Charles McGowen 2009-08-02 14:31:40 EDT
Also see bug: 

https://bugzilla.redhat.com/show_bug.cgi?id=491229
Comment 3 Daniel Walsh 2009-09-04 11:44:23 EDT

*** This bug has been marked as a duplicate of bug 491229 ***

Note You need to log in before you can comment on or make changes to this bug.