Bug 504725 - Output is too bold
Output is too bold
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: paps (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: 5.7
Assigned To: Akira TAGOH
desktop-bugs@redhat.com
:
Depends On:
Blocks: 590060
  Show dependency treegraph
 
Reported: 2009-06-08 22:05 EDT by Thomas Cameron
Modified: 2013-04-15 05:04 EDT (History)
13 users (show)

See Also:
Fixed In Version: paps-0.6.6-20.el5
Doc Type: Bug Fix
Doc Text:
Under certain circumstances, the paps utility could incorrectly typeset output using a heavy weight font. With this update, a patch has been applied to address this issue, and the output is now always rendered with a correct font weight.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-06 05:34:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Patch (686 bytes, patch)
2010-07-14 19:44 EDT, Bryan Mason
no flags Details | Diff

  None (edit)
Description Thomas Cameron 2009-06-08 22:05:50 EDT
Description of problem:
RHEL 5.3 contains paps-0.6.6.  paps-0.6.8 is available in F10.  Is there any way we could get paps updated for RHEL 5.4?
Comment 1 Akira TAGOH 2009-06-10 08:13:48 EDT
That would be better describing the business case and/or file an issue to Issue Tracker if your customer is accessible.
Comment 2 Thomas Cameron 2009-06-10 08:37:13 EDT
Understood.  All I have right now is one of my teammate's customer saying "it fixes some problems we have."  I am trying to get more information but my teammate is travelling right now so that's tough.  More info to follow as soon as I get it.
Comment 5 Akira TAGOH 2009-06-16 00:41:56 EDT
It may be too late to propose this to rhel-5.4 because public beta is coming soon. so trying to propose for 5.5.
Comment 6 Akira TAGOH 2009-06-16 00:44:58 EDT
Please explain what kind of bugs your customer faced too. we might backport a fix in some cases.
Comment 7 marc skinner 2009-06-16 15:54:49 EDT
The bug this addresses:

RHEL5 CUPS 1.2.4 output originally came out bolder than RHEL4 CUPS 1.1.2
Comment 8 marc skinner 2009-06-16 15:55:59 EDT
in a mixed environment of RHEL5/4 the output from the same print job would come out different.  it should be consistent.
Comment 9 RHEL Product and Program Management 2009-11-06 13:58:10 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 10 Bryan Mason 2010-07-14 19:44:54 EDT
Created attachment 431948 [details]
Proposed Patch

Patch adapted from upstream.  Fixed the problem in my testing.
Comment 11 Maarten Broekman 2010-07-16 08:59:17 EDT
Can this fix be included in RHEL5.6 please?
Comment 16 Robin R. Price II 2010-10-29 10:18:57 EDT
The work around for this is:

Change line 48 in /etc/cups/mime.convs:

from:    text/plain              application/postscript  33      texttopaps
to:      text/plain              application/postscript  33      texttops

Then restart cups.

Also, if you want to see the difference without making those changes, just do this:

1. echo abcde | /usr/lib/cups/filter/texttops 1 x '' 1 '' > cups.ps
2. echo abcde | /usr/lib/cups/filter/texttopaps 1 x '' 1 '' > paps.ps

3. evince cups.ps & evince paps.ps


----


This has always been an issue for RHEL4 print servers migrating to RHEL5.  lpoptions will not work correctly during the migration until you switch the filter from paps to ps again.

~rp
Comment 21 Akira TAGOH 2011-02-24 06:13:02 EST
Fixed in paps-0.6.6-20.el5
Comment 23 Jaromir Hradilek 2011-02-28 09:05:30 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Under certain circumstances, the paps utility could incorrectly typeset output using a heavy weight font. With this update, a patch has been applied to address this issue, and the output is now always rendered with a correct font weight.
Comment 24 Vasiliy Sharapov 2011-03-30 11:08:57 EDT
Marking as VERIFIED because this is fixed, but I must mention that the related bug https://bugzilla.redhat.com/show_bug.cgi?id=537450 appears to still be there.
Comment 25 errata-xmlrpc 2011-04-06 05:34:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0417.html

Note You need to log in before you can comment on or make changes to this bug.