Bug 504771 - clamav-milter cannot be started via init script
clamav-milter cannot be started via init script
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: clamav (Show other bugs)
el5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 06:17 EDT by Milos Malik
Modified: 2011-04-07 18:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-07 18:02:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2009-06-09 06:17:18 EDT
Description of problem:
An unrecognized option in init script causes that clamav-milter does not start.

Version-Release number of selected component (if applicable):
RHEL5-Server-U3
clamav-milter-sysv-0.95.1-1.el5
clamav-0.95.1-1.el5
clamav-filesystem-0.95.1-1.el5
clamav-data-0.95.1-1.el5
clamav-milter-0.95.1-1.el5
clamav-lib-0.95.1-1.el5

How reproducible:
always

Steps to Reproduce:
# /etc/init.d/clamav-milter start
Starting clamav-milter: clamav-milter: unrecognized option `--pidfile=/var/run/clamav-milter/clamav-milter.pid'
ERROR: Unknown option passed
ERROR: Can't parse command line options
[FAILED]
  
Actual results:
init script fails

Expected results:
init script works well
Comment 1 Christopher McCrory 2009-07-04 12:41:08 EDT
easy workaround:

cat /etc/sysconfig/clamav-milter 
PIDFILE=' '
#XXCLAMAV_FLAGS='-lo -c /etc/clamd.d/milter.conf local:/var/run/clamav-milter/clamav.sock'
CLAMAV_FLAGS='-c /etc/clamd.d/milter.conf '


and the default /etc/clamd.d/milter.conf does not work.  Just two of many problems with the fedora maintainers rpm init system.
Comment 2 Göran Uddeborg 2009-09-07 14:59:14 EDT
This is a duplicate of bug 495502, isn't it?
Comment 3 Nick Bebout 2011-03-04 21:03:52 EST
Please try the new package that is in epel-testing.  It's based off of a new spec and is upgraded to 0.97.
Comment 4 Nick Bebout 2011-04-07 18:02:41 EDT
They should be pushed to stable, or will be soon.  Please reopen if bug still exists.

Note You need to log in before you can comment on or make changes to this bug.