Bug 504772 - popt for epel-5
popt for epel-5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: popt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 06:20 EDT by Roy Rankin
Modified: 2009-06-09 06:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 06:29:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy Rankin 2009-06-09 06:20:53 EDT
Description of problem:
I am trying to add Gpsim to epel-5 however it requires popt-devel to build. Would you please build popt in epel-5 so it is available there for other programs.

regards,
Roy Rankin
Comment 1 Robert Scheck 2009-06-09 06:29:22 EDT
Well, popt in RHEL and CentOS is part of the base system, not of EPEL. So I
can't touch the package at all. Replace the BuildRequires of "popt-devel" simply
by "%{_includedir}/popt.h" to work around the issue. The popt package itself is
providing the content of -devel subpackage at RHEL and CentOS. The issue should
be gone with RHEL 6 and derivates.

Note You need to log in before you can comment on or make changes to this bug.