Bug 504824 - editing eth1 breaks bond
editing eth1 breaks bond
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
: Patch
Depends On:
Blocks: 668957
  Show dependency treegraph
 
Reported: 2009-06-09 12:11 EDT by Jeff Bastian
Modified: 2012-02-21 01:09 EST (History)
5 users (show)

See Also:
Fixed In Version: system-config-network-1.3.99.20-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:09:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to disable "Bind to MAC address" for slave devices (592 bytes, patch)
2009-06-09 17:07 EDT, Jeff Bastian
no flags Details | Diff

  None (edit)
Description Jeff Bastian 2009-06-09 12:11:55 EDT
Description of problem:
If eth0 and eth1 are bonded as bond0, and you edit eth1 with system-config-network and bind it to its MAC address, it breaks the bond pair because it uses the MAC address from eth0.

For example, given a system with
   eth0  00:11:22:33:44:55
   eth1  00:11:22:33:44:FF
Use s-c-network to edit eth1, go to the Hardware Device tab, enable "Bind to MAC address", and hit the Probe button, and it will put the bond0 (same as eth0) MAC address in /etc/sysconfig/network-scripts/ifcfg-eth1 as
   HWADDR=00:11:22:33:44:55

Either the Probe function needs to correctly probe for the MAC address, or s-c-network should not allow one to edit slave interfaces.


Version-Release number of selected component (if applicable):
system-config-network-1.3.99.12-1.el5

How reproducible:
every time

Steps to Reproduce:
1. configure a system so eth0 and eth1 are bonded
2. launch system-config-network
3. select eth1 and hit Edit
4. go to Hardware Devices tab
5. enable "Bind to MAC address" and hit Probe button
6. click OK, File->Save, File->Quit
7. service network restart
  
Actual results:
bond0 fails to start correctly and this error is printed while starting network services:
  Device eth1 has different MAC address than expected, ignoring.

eth1 is also renamed to an internal random name like dev10003
  $ ifconfig -a
  ...
  dev10003  Link encap:Ethernet  HWaddr 00:11:22:33:44:FF
            BROADCAST MULTICAST  MTU:1500  Metric:1        
  ...

Expected results:
s-c-network prevents the user from corrupting the bond configuration

Additional info:
Comment 1 Jeff Bastian 2009-06-09 17:07:50 EDT
Created attachment 347088 [details]
patch to disable "Bind to MAC address" for slave devices

Here's a simple patch for system-config-network-1.3.99.12 to disable the "Bind to MAC address" option on bond slave devices.
Comment 4 RHEL Product and Program Management 2009-11-06 14:23:56 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 RHEL Product and Program Management 2010-08-09 15:43:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-05-31 11:27:56 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 errata-xmlrpc 2012-02-21 01:09:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0231.html

Note You need to log in before you can comment on or make changes to this bug.