Bug 504853 - RFE: add UI for importing existing VM images
RFE: add UI for importing existing VM images
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
:
: 473435 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 14:47 EDT by erikj
Modified: 2010-05-05 16:17 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 16:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description erikj 2009-06-09 14:47:04 EDT
When creating a new virtual machine with F11 virt-manager...

The dialog asks you early on for an install method.  In later steps/screens of
the dialog, it allows you to associate an existing disk image/storage.

One big use case of existing storage would be an already-installed image.
Perhaps they used other tools to make the image, or copied it from elsewhere,
etc.

Therefore, to construct a new machine using an existing root, I'd suggest
asking for this as a choice at the same time you offer installation methods.

My personal suggestion would be to allow one to have a choice of using an
existing image in Step 1 of 'Create a new virtual machine'.  I'd suggest
something like this:

Choose how you would like to install the operating system:
 * Local install media (ISO image or CDROM)
 * Network Install (HTTP, FTP, or NFS)
 * Network Boot (PXE)
 * Use pre-existing storage for root

If they choose 'Use pr-existing storage for root', it could ask for the path in
step 2 where it would normally ask for the ISO path, etc.

As it sits today, creating a new node but avoiding the installation is a bit
quirky.  For example, I normally choose "PXE" so that I can associate the
root disk in the later step.  However, that means the first boot tries to PXE
and I have to shutdown the machine and start it again to use that pre-existing
storage as the root device.

This is just a suggestion/RFE.

Thanks much for all the improvements in virt-manager/libvirt that I see in
F11.


# rpm -q qemu-kvm libvirt virt-manager
qemu-kvm-0.10.4-4.fc11.x86_64
libvirt-0.6.2-11.fc11.x86_64
virt-manager-0.7.0-5.fc11.x86_64
Comment 1 Mark McLoughlin 2009-06-22 09:01:47 EDT
The "New VM" wizard is intended to only be for creating new VMs from scratch

The virt-image tool (see virt-image(1) and virt-image(5) man pages) is really what you want for creating a VM from an existing image

Moving to upstream virt-manager as an RFE for "import existing image" support. It may be decided not to add this in order to keep the UI less confusing
Comment 2 Gene Czarcinski 2009-07-13 11:14:51 EDT
There is confusion and then there is confusion.  virt-manager should support importing an existing image for both completeness and usability.  Forcing the user to use command line programs is more confusing.
Comment 3 Cole Robinson 2009-07-13 12:28:21 EDT
Adding UI to support this is target for after F12 GA. It's really only in the planning stages though.

Rather than use virt-image, which is really for distributing appliances (and there isn't an easy way build virt-image XML at the moment), you can use the --import flag to virt-install, so:

virt-install ... --disk path=/path/to/my/disk --import ...

There is an example for this use case in the virt-install man pages.
Comment 4 Cole Robinson 2009-09-24 14:48:24 EDT
*** Bug 473435 has been marked as a duplicate of this bug. ***
Comment 5 Cole Robinson 2010-05-05 16:17:24 EDT
This is available in virt-manager 0.8.4

Note You need to log in before you can comment on or make changes to this bug.