Bug 504856 - up2date package, unable to rollback packages due to bad skip list execption
up2date package, unable to rollback packages due to bad skip list execption
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.7.z
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jan Pazdziora
Martin Minar
na
: ZStream
Depends On:
Blocks: 520122
  Show dependency treegraph
 
Reported: 2009-06-09 14:49 EDT by wes hayutin
Modified: 2016-07-03 20:54 EDT (History)
10 users (show)

See Also:
Fixed In Version: up2date-4.9.1-15.el4
Doc Type: Bug Fix
Doc Text:
This update ensures that up2date does not resolve dependencies for the packages that are being uninstalled when the transaction does not involve a package removal only.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-16 09:13:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-09 14:49:09 EDT
Description of problem:

rhel 4u7, up2date

1. register a rhel 4u7 server to satellite
2. create a snapshot profile
3. update serveral packages (in this case)
ash, audit, audit-libs, autofs, bash
4. rollback

get 

D: do_call packages.runTransaction ({'packages': [[['ash', '0.3.8', '20.el4_7.1', '', ''], 'e'], [['audit', '1.0.16', '4.el4', '', ''], 'e'], [['audit-libs', '1.0.16', '4.el4', '', ''], 'e'], [['autofs', '4.1.3', '238', '1', ''], 'e'], [['bash', '3.0', '21.el4', '', ''], 'e'], [['ash', '0.3.8', '20', '', ''], 'i'], [['audit', '1.0.16', '3.el4', '', ''], 'i'], [['audit-libs', '1.0.16', '3.el4', '', ''], 'i'], [['autofs', '4.1.3', '234', '1', ''], 'i'], [['bash', '3.0', '19.7', '', ''], 'i']]},)
D: availablePackageList::channels: <up2date_client.rhnChannel.rhnChannelList instance at 0xb7a8ad6c>
D: listAllPackages Fetched via: diskcache
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 345, in ?
    handle_action(action)
  File "/usr/sbin/rhn_check", line 218, in handle_action
    (status, message, data) = run_action(method, params)
  File "/usr/sbin/rhn_check", line 174, in run_action
    (status, message, data) = do_call(method, params)   
  File "/usr/sbin/rhn_check", line 91, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 428, in runTransaction
    (ts, added, removed) = up2date.genTransaction(tsd)
  File "/usr/share/rhn/up2date_client/up2date.py", line 589, in genTransaction
    resolveRemovalDeps(ts)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1154, in resolveRemovalDeps
    resolveRemovalDeps(ts)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1154, in resolveRemovalDeps
    resolveRemovalDeps(ts)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1146, in resolveRemovalDeps
    raise up2dateErrors.RpmRemoveSkipListError, depName
up2date_client.up2dateErrors.RpmRemoveSkipListError: Could not remove package "kernel-2.6.9-78.EL". It was on the RemoveSkipList



I should not get a kernel pkg skip list for this particular set of pkgs.  This happens w/ any rollback.
Comment 12 Bart Dijkman Dulkes 2009-07-29 07:26:47 EDT
I am experiencing the same problem after updating my system from rhel4u6 to rhel4u8. It looks like the kernel is added to the "Remove list" by a dependency check of up2date.
Comment 19 Jan Pazdziora 2010-07-26 11:14:46 EDT
Taking.
Comment 26 Jaromir Hradilek 2011-01-17 06:55:52 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
This update ensures that up2date does not resolve dependencies for the packages that are being uninstalled when the transaction does not involve a package removal only.
Comment 27 errata-xmlrpc 2011-02-16 09:13:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0240.html

Note You need to log in before you can comment on or make changes to this bug.