Bug 504902 - gfx plotting glitches
gfx plotting glitches
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 21:34 EDT by William A. Mahaffey III
Modified: 2018-04-11 05:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 19:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
incomplete plot of mesh around NACA 0012 airfoil .... (76.68 KB, image/png)
2009-06-09 21:34 EDT, William A. Mahaffey III
no flags Details
updated plot (w/o dialog box obscuring relevant detail :-/ ....) (135.05 KB, image/png)
2009-06-09 22:11 EDT, William A. Mahaffey III
no flags Details
dmesg file from this machine .... (28.39 KB, text/plain)
2009-09-18 09:05 EDT, William A. Mahaffey III
no flags Details
xorg.conf for this box .... (796 bytes, text/plain)
2009-09-18 09:06 EDT, William A. Mahaffey III
no flags Details
xorg.*.log for this machine .... (33.98 KB, text/plain)
2009-09-18 09:07 EDT, William A. Mahaffey III
no flags Details
Xorg.0.log for FC6 (remote) box .... (39.21 KB, text/plain)
2009-09-18 09:11 EDT, William A. Mahaffey III
no flags Details
dmesg file from remote FC6 box .... (20.93 KB, text/plain)
2009-09-18 09:12 EDT, William A. Mahaffey III
no flags Details
xorg.conf for remote FC6 box .... (564 bytes, text/plain)
2009-09-18 09:12 EDT, William A. Mahaffey III
no flags Details

  None (edit)
Description William A. Mahaffey III 2009-06-09 21:34:50 EDT
Created attachment 347124 [details]
incomplete plot of mesh around NACA 0012 airfoil ....

Description of problem:I get glitches plotting fields of triangles using OpenGL under gnome desktop in my in-house CAD/FEA/mesh-generator program. Everything worked AOK until I upgraded about 4 weeks ago. plots are incomplete (only about 1/2 (~8000-10000) of the tris plot, all are present in model by inspection of tabular printout).


Version-Release number of selected component (if applicable): FC9 64-bit fully patched up as of Sunday (6/7/09).


How reproducible: difficult, try to plot array of tris yourself :-/ ....


Steps to Reproduce:
1.
2.
3.
  
Actual results: incomplete mesh plotted, only about ~9000 tris out of about 21,000 plot, apparently in order of generation, gets part way through plot & stops plotting them after about 9000-10000 plotted ....


Expected results: plot 'em all ....


Additional info:
Comment 1 William A. Mahaffey III 2009-06-09 22:11:41 EDT
Created attachment 347128 [details]
updated plot (w/o dialog box obscuring relevant detail :-/ ....)

let's try that plot again :-/ ....
Comment 2 William A. Mahaffey III 2009-06-13 18:04:08 EDT
I just upgraded to FC11 64-bit via preupgrade this A.M. & this is still a problem ....
Comment 3 William A. Mahaffey III 2009-06-14 12:45:16 EDT
Eeeeeeeek !!!! A clarification: This plot happens when I execute my code on another machine (tried both an FC6 box & an FC7 box, both 64-bit & both terminally patched up) & display on this (FC11) box. The code is invoked from CLI under rxvt, SSH'ed over to the other machines, which are both servers, running in runlevel 3. When I run the code on this box (invoked from CLI under rxvt/TCSH) & display on this box, the plot comes out AOK. Looks like a problem w/ FC6 & FC7 (both), 64-bit .... This all worked up until a few weeks ago when I did my last patch-ups for those machines ....
Comment 4 Matěj Cepl 2009-09-13 18:50:26 EDT
This is a strange bug. I wonder whether it is a hardware dependent. Probably the easiest way how to find a lot of information about your hardware would be if you attach to this bug your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Matěj Cepl 2009-09-13 18:52:13 EDT
And also, could you please provide steps to reproduce which I can follow (names of the packages to install, what data to use, what I need to do ... consider also I have no experience with this kind of programs)?

Thank you
Comment 6 William A. Mahaffey III 2009-09-18 09:05:20 EDT
Created attachment 361647 [details]
dmesg file from this machine ....
Comment 7 William A. Mahaffey III 2009-09-18 09:06:23 EDT
Created attachment 361648 [details]
xorg.conf for this box ....
Comment 8 William A. Mahaffey III 2009-09-18 09:07:34 EDT
Created attachment 361649 [details]
xorg.*.log for this machine ....
Comment 9 William A. Mahaffey III 2009-09-18 09:11:31 EDT
Created attachment 361652 [details]
Xorg.0.log for FC6 (remote) box ....
Comment 10 William A. Mahaffey III 2009-09-18 09:12:02 EDT
Created attachment 361653 [details]
dmesg file from remote FC6 box ....
Comment 11 William A. Mahaffey III 2009-09-18 09:12:34 EDT
Created attachment 361654 [details]
xorg.conf for remote FC6 box ....
Comment 12 William A. Mahaffey III 2009-09-18 09:14:13 EDT
I will (try to) generate a small program to duplicate this behavior by modifying 1 of the small OpenGL example programs, please be patient on this one :-) ....
Comment 13 William A. Mahaffey III 2009-09-20 11:13:46 EDT
Well .... after some messing around w/ writing the small test app, it appears that the problem is in the OpenGL V1.1 libraries in FC6 & FC7, specifically something in either the glVertexPointer routine or the glDrawElements routine (probably the latter, IMHO). When I plot tri's using the old-fashioned ((3-glVertex3d's-per-tri)-in-a-loop-over-all-tris) method, everything plots AOK. When I use the newer routines mentioned above, I get bad plots (in my sample code & in my other CAD code). Sooooooo .... I guess this is .... NOTABUG after all (unless the possibility of bad code from FC6 also being in RHEL5 is a problem).
Comment 14 Matěj Cepl 2009-10-12 19:33:14 EDT
Thanks for exhaustive analysis. Closing as NOTABUG then.

Note You need to log in before you can comment on or make changes to this bug.