Bug 504936 - Anaconda - install problem - mkfs/partitioning/filesystem issue?
Anaconda - install problem - mkfs/partitioning/filesystem issue?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:2f8d50ce9c666a176...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 00:31 EDT by Pat Gunn
Modified: 2009-09-29 17:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 15:00:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (361.88 KB, text/plain)
2009-06-10 00:31 EDT, Pat Gunn
no flags Details
Attached traceback automatically from anaconda. (349.04 KB, text/plain)
2009-09-29 17:49 EDT, Elio Maldonado Batiz
no flags Details

  None (edit)
Description Pat Gunn 2009-06-10 00:31:22 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iutil.py", line 112, in execWithRedirect
    raise RuntimeError, errstr
  File "/usr/lib/anaconda/booty/x86.py", line 76, in runGrubInstall
    root = instRoot)
  File "/usr/lib/anaconda/booty/x86.py", line 125, in installGrub
    self.runGrubInstall(instRoot, bootDev, cmds, cfPath)
  File "/usr/lib/anaconda/booty/x86.py", line 357, in writeGrub
    target, cfPath)
  File "/usr/lib/anaconda/booty/x86.py", line 534, in write
    justConfig | (not self.useGrubVal))
  File "/usr/lib/anaconda/bootloader.py", line 204, in writeBootloader
    justConfigFile)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1360, in handleRenderCallback
    self.currentWindow.renderCallback()
RuntimeError: Error running /sbin/grub-install: No such file or directory
Comment 1 Pat Gunn 2009-06-10 00:31:44 EDT
Created attachment 347150 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-06-10 07:51:24 EDT
Seems to be errors surfacing while installing packages.  Many critical packages failed to install properly (including grub).

/mnt/sysimage/root/install.log:
Installing libgcc-4.4.0-4.x86_64
warning: libgcc-4.4.0-4.x86_64: Header V3 RSA/SHA256 signature: NOKEY, key ID d22e77f2
error: unpacking of archive failed on file /usr/sbin/libgcc_post_upgrade;4a2f31b3: cpio: mkdir failed - Resource temporarily unavailable
...
Installing filesystem-2.4.21-1.fc11.x86_64
error: unpacking of archive failed on file /bin: cpio: mkdir failed - Resource temporarily unavailable
...
Installing grub-0.97-50.fc11.x86_64
warning: %post(grub-0.97-50.fc11.x86_64) scriptlet failed, exit status 127


Is it possible you have a failing disk?  From the logs you posted ...

<6>sda1: rw=0, want=116129808, limit=102400000
<2>EXT3-fs error (device sda1): read_inode_bitmap: Cannot read inode bitmap - block_group = 443, inode_bitmap = 14516225
<2>EXT3-fs error (device sda1) in ext3_new_inode: IO failure
<6>attempt to access beyond end of device
Comment 3 Pat Gunn 2009-06-20 22:57:18 EDT
I don't think I have a failing disk, but using the utility console to manually partition and make filesystems gave me a working install. I am not interested in further debugging this, so you may mark it closed if you like.
Comment 4 Elio Maldonado Batiz 2009-09-29 17:49:55 EDT
Created attachment 363059 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.