Bug 504937 - Install in AHCI mode; won't boot unless change to IDE/compatibility mode
Install in AHCI mode; won't boot unless change to IDE/compatibility mode
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 00:35 EDT by Spencer Brown
Modified: 2009-06-22 16:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 16:36:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Spencer Brown 2009-06-10 00:35:53 EDT
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322)

System has Intel DQ35JO motherboard (Q35 Express chipset) with a Core 2 Duo processor and 8GB memory.  AHCI mode is set in BIOS for SATA.  Install Fedora 11, customize disk partitioning, remove LVM, create an ext4 primary partition with / mounted on it, then complete install and all seems normal.  On first boot, the system simply hangs with a blank screen and blinking cursor.  

Go into BIOS and switch SATA to IDE (compatibility) mode, and first boot occurs normally.

This behavior was not seen on Fedora 10.  You could set AHCI mode, install, and reboot, and it would work.  

What made this worse on my system was that I could not get into the BIOS to change the setting unless I physically disconnected my SATA drives.  

Reproducible: Always

Steps to Reproduce:
1.  Install Fedora 11 i386 with SATA mode set to AHCI on Intel DQ35JO motherboard.
2.  Attempt to reboot, note blank screen with blinking cursor.
3.  Change to IDE (compatibility mode) in BIOS for SATA drives, observe boot now successful.


Expected Results:  
Fedora 11 should install the correct drivers in AHCI mode so that reboot is possible.  The user experience is:  "I installed Fedora 11 and my machine is bricked!"  This is not exactly true but in my case I really thought I had a dead machine.  I had to physically disconnect the drives before it would let me get into the BIOS, and then I just guessed that the AHCI/IDE setting had something to do with it.
Comment 1 Hans de Goede 2009-06-10 14:06:21 EDT
You had to disconnect the drives before it would let you in the BIOS ?
Did you try power cycling the machine ?

Also did you ever get the bootloader press a key for menu 3-2-1 countdown ?
Comment 2 Spencer Brown 2009-06-10 18:54:13 EDT
> You had to disconnect the drives before it would let you in the BIOS ?

I was astonished at this but it absolutely was the case.  I don't imagine this is a Linux issue, probably some BIOS weirdness.  

> Did you try power cycling the machine ?

Yes of course.  I tried everything I could think of.  I power cycled it, I pulled the power cord and cycled it again, I hit the reset button, I removed all extraneous connections (LAN, etc.), I tried holding down the F2 key during boot, I tried hitting the F2 key intermittently during boot, etc. etc.  Nothing worked.

> Also did you ever get the bootloader press a key for menu 3-2-1 countdown ?

No.  It seemed like it never even got to the boot sequence out of the BIOS.  Normally as it goes through the boot sequence the BIOS puts up two-letter codes in the lower right corner of the screen, to denote where it is in the sequence.  I saw none of those.  It just went straight to a black screen and a flashing cursor in the upper left hand corner.
Comment 3 Hans de Goede 2009-06-11 03:11:38 EDT
Really weird.

Can you please contact Intel about this, since you never even got to the BIOS POST this feels like a hardware issue (or bad hardware OS interaction) to me.

Intel is pretty serious about Linux support these days. If you don't manage to get a serious response from them let me know and I'll see if I can get some input from them.
Comment 4 Spencer Brown 2009-06-11 11:29:31 EDT
Yes I will follow up with Intel.  

Is there still a Fedora 11 problem here?  Isn't it failing to detect my AHCI and installing IDE drivers instead?
Comment 5 Hans de Goede 2009-06-11 13:21:40 EDT
(In reply to comment #4)
> Yes I will follow up with Intel.  
> 
> Is there still a Fedora 11 problem here?  Isn't it failing to detect my AHCI
> and installing IDE drivers instead?  

There might be, but in my experience F-11 will happily work with either native
SATA or AHCI driver. I've toggled AHCI on/off in the BIOS on multiple machines
and F-11 just keeps on working both when going from no AHCI -> AHCI and the otherway around.

So given that with AHCI left enabled the system wouldn't even get to POST, until
we know more there is nothing we can do.
Comment 6 Spencer Brown 2009-06-22 16:36:44 EDT
RESOLVED. I cannot reproduce the behavior now and Fedora 11 is installing fine.

I fixed it by (1) upleveling the BIOS and (2) deleting all partitions on the hard drive and re-doing the install. 

It's one of two things that caused this. 

1) Downlevel BIOS which I upgraded. (I don't think it's this.,)

2) I had the boot drive on SATA port 1. I switched it to SATA port 0. 

Or it could have just been something transient.

Note You need to log in before you can comment on or make changes to this bug.