Bug 50495 - /etc/pcmcia/network not invoked when unplugging a 3c59x card.
/etc/pcmcia/network not invoked when unplugging a 3c59x card.
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-31 14:02 EDT by Fabrice Bellet
Modified: 2015-01-04 17:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 17:40:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2001-07-31 14:02:31 EDT
The bug seems to be always reproductible. Iface config is made with
/etc/hotplug/net.agent, but Iface removal used to be done by pcmcia
network script. This doesn't seem to work since 2 previous rawhide
releases. I have few idea on how to fix this. The log info is :

Jul 31 20:02:12 localhost kernel: Linux Kernel Card Services 3.1.22
Jul 31 20:02:12 localhost kernel:   options:  [pci] [cardbus] [pm]
Jul 31 20:02:12 localhost kernel: PCI: Found IRQ 11 for device 00:02.0
Jul 31 20:02:12 localhost kernel: PCI: Sharing IRQ 11 with 00:06.0
Jul 31 20:02:12 localhost kernel: PCI: Sharing IRQ 11 with 01:00.0
Jul 31 20:02:12 localhost kernel: PCI: Found IRQ 11 for device 00:02.1
Jul 31 20:02:12 localhost kernel: Yenta IRQ list 0298, PCI irq11
Jul 31 20:02:12 localhost kernel: Socket status: 30000006
Jul 31 20:02:12 localhost kernel: Yenta IRQ list 0298, PCI irq11
Jul 31 20:02:12 localhost kernel: Socket status: 30000006
Jul 31 20:02:12 localhost cardmgr[2310]: starting, version is 3.1.22
Jul 31 20:02:12 localhost cardmgr[2310]: config error, file './config.opts'
line 8: no function bindings
Jul 31 20:02:12 localhost cardmgr[2310]: watching 2 sockets
Jul 31 20:02:12 localhost kernel: cs: IO port probe 0x0c00-0x0cff: clean.
Jul 31 20:02:12 localhost kernel: cs: IO port probe 0x0800-0x08ff: clean.
Jul 31 20:02:12 localhost kernel: cs: IO port probe 0x0100-0x04ff:
excluding 0x170-0x177 0x370-0x377 0x4d0-0x4d7
Jul 31 20:02:13 localhost kernel: cs: IO port probe 0x1000-0x17ff: clean.
Jul 31 20:02:13 localhost kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Jul 31 20:02:18 localhost kernel: cs: cb_alloc(bus 2): vendor 0x10b7,
device 0x5157
Jul 31 20:02:18 localhost kernel:   got res[1000:107f] for resource 0 of
PCI device 10b7:5157
Jul 31 20:02:18 localhost kernel:   got res[10400000:1040007f] for resource
1 of PCI device 10b7:5157
Jul 31 20:02:18 localhost kernel:   got res[10400080:104000ff] for resource
2 of PCI device 10b7:5157
Jul 31 20:02:18 localhost kernel:   got res[10000000:1001ffff] for resource
6 of PCI device 10b7:5157
Jul 31 20:02:18 localhost kernel: PCI: Enabling device 02:00.0 (0000 -> 0003)
Jul 31 20:02:18 localhost kernel: 02:00.0: 3Com PCI 3CCFE575BT Cyclone
CardBus at 0x1000, PCI: Setting latency timer of device 02:00.0 to 64
Jul 31 20:02:18 localhost kernel:  00:00:86:13:3e:f9, IRQ 11
Jul 31 20:02:18 localhost kernel:   product code 4e56 rev 07.1 date 03-10-98
Jul 31 20:02:18 localhost kernel: 02:00.0: CardBus functions mapped
10400080->cc89e080
Jul 31 20:02:18 localhost kernel:   8K byte-wide RAM 5:3 Rx:Tx split, MII
interface.
Jul 31 20:02:18 localhost kernel:   MII transceiver found at address 0,
status 7809.
Jul 31 20:02:18 localhost kernel:   Enabling bus-master transmits and
whole-frame receives.
Jul 31 20:02:18 localhost cardmgr[2310]: initializing socket 0
Jul 31 20:02:18 localhost kernel: 02:00.0: scatter/gather disabled. h/w
checksums enabled
Jul 31 20:02:18 localhost cardmgr[2310]: socket 0: 3Com 3CCFE575B/3CXFE575B
Fast EtherLink XL
Jul 31 20:02:18 localhost cardmgr[2310]:   product info: "3Com
Corporation", "3CCFE575BT", "LAN Cardbus Card", "001"
Jul 31 20:02:18 localhost cardmgr[2310]:   manfid: 0x0101, 0x5157 
function: 6 (network)
Jul 31 20:02:18 localhost cardmgr[2310]:   PCI id: 0x10b7, 0x5157
Jul 31 20:02:18 localhost kernel: eth0: using default media MII
Jul 31 20:02:27 localhost sendmail: sendmail shutdown succeeded
Jul 31 20:02:28 localhost sendmail: sendmail startup failed
Jul 31 20:02:47 localhost kernel: cs: cb_free(bus 2)
Jul 31 20:02:47 localhost cardmgr[2310]: shutting down socket 0

[root@bonobo bellet]# more /var/lib/pcmcia/stab 
Socket 0: 3Com 3CCFE575B/3CXFE575B Fast EtherLink XL
Socket 1: empty

[root@bonobo bellet]# lsmod
Module                  Size  Used by
ds                      6960   2 
yenta_socket           10896   2 
pcmcia_core            41856   0  [ds yenta_socket]
3c59x                  26144   1 
binfmt_misc             6272   1 
nfsd                   69760   8  (autoclean)
lockd                  51792   1  (autoclean) [nfsd]
sunrpc                 63152   1  (autoclean) [nfsd lockd]
mwave                  29968   4 
autofs                 10816   1  (autoclean)
appletalk              20528   0  (autoclean)
ipx                    16160   0  (autoclean)
hid                    18160   0  (unused)
input                   3456   0  [hid]
usb-uhci               21440   0  (unused)
usbcore                50432   1  [hid usb-uhci]
ext3                   50656   3 
jbd                    39376   3  [ext3]

[root@bonobo bellet]# more /etc/sysconfig/pcmcia 
PCMCIA=yes
PCIC=yenta_socket
#PCIC=i82365
PCIC_OPTS=
CORE_OPTS=
CARDMGR_OPTS=-v


[root@bonobo bellet]# egrep ^[a-z] /etc/pcmcia/config.opts  
include port 0x100-0x4ff, port 0x800-0x8ff, port 0xc00-0xcff
include memory 0xc0000-0xfffff
include memory 0x60000000-0x60ffffff
include port 0x1000-0x17ff
include port 0xa00-0xaff
exclude port 0x2f8-0x2ff
exclude irq 3
exclude irq 4
exclude irq 5
exclude irq 7
module "ray_cs" opts "essid=ADHOC_ESSID hop_dwell=128 beacon_period=256
translate=1"


[root@bonobo bellet]# rpm -qa | grep kernel-pcmcia
kernel-pcmcia-cs-3.1.27-5
[root@bonobo bellet]# more /proc/version          
Linux version 2.4.6-3.1 (bhcompile@stripples.devel.redhat.com) (gcc version
2.96 20000731 (Red Hat Linux 7.1 2.96-94)) #1 Tue Jul 24 14:54:56 EDT 2001
Comment 1 Bill Nottingham 2001-08-05 17:40:29 EDT
? You're saying the module doesn't get removed/the interface doesn't get
unloaded when you eject the card?
Comment 2 Fabrice Bellet 2001-08-06 05:29:33 EDT
The interface is unloaded, but /etc/pcmcia/network is not executed, neither
/etc/sysconfig/network-scripts/ifdown. So cleaning tasks, like killing
dhcpcd/pump, are not executed. The problem is that dhcpcd/pump stay
alive after the interface is unloaded.

Note You need to log in before you can comment on or make changes to this bug.