Bug 504976 - [oocalc] The precision of Number Format:Currency for Yen is not right in RHEL5 Client x86_64(ja_JP)
[oocalc] The precision of Number Format:Currency for Yen is not right in RHE...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
: 504974 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 05:29 EDT by Rita Wu
Modified: 2013-07-02 21:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 05:48:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rita Wu 2009-06-10 05:29:32 EDT
Description of problem:

".00" won't be added, after clicking the "Number Format:Currency" icon with gold coin on the object bar in RHEL5 Client x86_64(ja_JP).

Version-Release number of selected component (if applicable):
openoffice.org-2.3.0-6.11.el5

How reproducible:


Steps to Reproduce:
1.Launch the oocalc
2.Input some numbers into cells(one cell,one number,e.g.4), then select one cell or range of cells with numbers
3.Click the "Number Format:Currency" icon with gold coin on the object bar.
  
Actual results:
¥4

Expected results:
¥4.00

Additional info:
Comment 1 Caolan McNamara 2009-06-10 05:48:26 EDT
See, CLDR "digit rounding for the currency":

i.e.

http://www.unicode.org/cldr/data/charts/supplemental/detailed_territory_currency_information.html#format_info

The default rounding for Yen is no digits, unlike e.g. Euro or US Dollars which have the "typical" two
Comment 2 Caolan McNamara 2009-06-10 05:49:07 EDT
*** Bug 504974 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.