Bug 504980 - ntp version on fc11 lower than ntp version of fc10
ntp version on fc11 lower than ntp version of fc10
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
11
All Linux
low Severity urgent
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
: 505177 506040 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 05:58 EDT by Mohammed Arafa
Modified: 2009-06-16 02:58 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 02:58:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Arafa 2009-06-10 05:58:23 EDT
Description of problem:
on fc10 the version of ntp is Version     : 4.2.4p7  while on fc11 the version is ntp-4.2.4p6-4.fc11.i586.rpm. 

the result is that on a fedora11 upgrade (i did a preupgrade) ntp is NOT update and does NOT run as it expects lower version of ssl as well as per the message:

Starting ntpd: ntpd: error while loading shared libraries: libcrypto.so.7: cannot open shared object file: No such file or directory



Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1.upgrade
2.start ntp service
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anatoly Pugachev 2009-06-10 11:31:05 EDT
acknowledge, on my system this has also happened. a simple fix would be remote fc10 packages for ntp and ntpdate and install thouse coming from fc11.
Comment 2 Anatoly Pugachev 2009-06-10 11:32:00 EDT
s/remote/to remove/

spelling sorry.
Comment 3 Mohammed Arafa 2009-06-10 17:31:14 EDT
i tried that, it has a dependency list that includes anaconda, system-config-date, firstboot etc.

which is why i left it as is.
Comment 4 Miroslav Lichvar 2009-06-11 01:44:58 EDT
*** Bug 505177 has been marked as a duplicate of this bug. ***
Comment 5 Anatoly Pugachev 2009-06-11 02:19:48 EDT
Mohammed, force deinstallation with "rpm -e --nodeps ntp", i know it is not proper, but you're going to install ntp right after that, so nothing will be broken actually.
Comment 6 Mohammed Arafa 2009-06-11 04:16:22 EDT
thanks

the complete process is:

rpm -e --nodeps ntp ntpdate
yum -y install ntp ntpdate

chkconfig ntpd on
chkconfig ntpdate on

system-config-date to re enter your ntp servers if you are not using the default OR edit /etc/ntp.conf.

i did not prefer to reuse /etc/ntp.conf.rpmsave
Comment 7 Milan Kerslager 2009-06-13 05:05:23 EDT
Please provide updated package for F11 to get ntpd daemon work after update.
Comment 8 Miroslav Lichvar 2009-06-13 06:18:50 EDT
The package is waiting for next push:

https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5674
Comment 9 Need Real Name 2009-06-14 05:31:28 EDT
Thanks - rpm -U ntp-4.2.4p7-2.fc11.x86_64.rpm  ntpdate-4.2.4p7-2.fc11.x86_64.rpm from testing fixes the problem and makes "package-cleanup --problems happy"
Comment 10 Miroslav Lichvar 2009-06-15 07:53:29 EDT
*** Bug 506040 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.