Bug 504984 - [.sxw]Some of the items in the status bar don't work.
[.sxw]Some of the items in the status bar don't work.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 06:08 EDT by Rita Wu
Modified: 2013-07-02 21:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 10:38:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the .sxw document (41.41 KB, application/vnd.sun.xml.writer)
2009-06-10 21:39 EDT, Rita Wu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 102841 None None None Never

  None (edit)
Description Rita Wu 2009-06-10 06:08:55 EDT
Description of problem:
 To .sxw document, the forth item in the status bar is blank. and when double click it, it still blank. To the fifth item in the status bar,when it is EXT mode, it can not be changed to ADD mode, only can be changed to STD mode.

 But to other document style, this function is OK.


Version-Release number of selected component (if applicable):

openoffice.org-2.3.0-6.11.el5
How reproducible:


Steps to Reproduce:
1.Open an existing text document(.sxw)
2.Click on the forth item in the status bar
   *Note: INSERT-you could insert new words into the document

          OVER-you will replace the existing content in the
          document
3.Click the fifth item in the status bar

   * Note: STD select cell according to yourself;

          EXT:select one cell ,and then turn the selection status to
          EXT,and click on the other cell,it will select a range from
          the first selected cell to the second selected cell.
          ADD:add a cell into current selected range of cells
4.Insert a table,and click in the cell,watch the last item in
           the status bar
  
Actual results:

1.The forth item in the status bar is blank. and when double click it, it still blank.
2.when it is EXT mode, it can not be changed to ADD mode.

Expected results:
1.There is INSERT or OVER in the forth item in the status bar.At the same time, they can be correctly used.
2.Change the mode to ADD,  a cell will be added into current selected range of cells.

Additional info:
Comment 1 Caolan McNamara 2009-06-10 06:55:04 EDT
I have no such problems. Are you sure for "1.The forth item in the status bar is blank. and when double click it, it still blank" that you have a read-write document. Maybe you opened a read-only document, in which case you can't INSERT or OVERWRITE any content so its now shown.
Comment 2 Rita Wu 2009-06-10 21:39:33 EDT
Created attachment 347323 [details]
the .sxw document
Comment 3 Rita Wu 2009-06-10 23:23:13 EDT
(In reply to comment #1)
> I have no such problems. Are you sure for "1.The forth item in the status bar
> is blank. and when double click it, it still blank" that you have a read-write
> document. Maybe you opened a read-only document, in which case you can't INSERT
> or OVERWRITE any content so its now shown.  

Yes, I'm sure that I have the rights to r-w. Maybe you can try the .sxw document I just attached.
Comment 4 Caolan McNamara 2009-06-11 05:57:50 EDT
Ah, edit->changes and untick record and then it should appear. "overwrite" mode (which is what you also get if you simply press the "insert" key to toggle between them) is disabled when change tracking is enabled, in order to correctly record what changes you are making.

Can you try with a document that does not have change tracking enabled, or just toggle it off in this document.
Comment 5 Rita Wu 2009-06-12 05:46:54 EDT
after untick Edit->Changes->Record and press Insert key, we can use the function of insert and overwrite.
but what about the ADD mode?  Is this function OK or just I need to set before use it?
Comment 6 Caolan McNamara 2009-06-12 06:20:32 EDT
First just try, without any tables involved, to use those modes to get a feel for what they do. STD is a normal selection, EXT means that when you have a selection, then where you click to the selection extends to, and ADD then means you can make a *second* selection and both selections will exist as a "multi-selection"

Tables make things very complicated, with their grid structure its not really possible to select e.g. three arbitrary cells like two from one column using STD, to then click ADD and add one from a different column, so when you enter a table some of those modes which can't be implemented for tables are disabled.

There isn't a bug there with ADD and those tables, it seems to be working as currently intended. Though implementing arbitrary cell selection would be cool and allow ADD to be enabled when inside tables. So I don't think anything is broken with ADD not available inside tables, just not possible with the current technology.
Comment 7 Caolan McNamara 2009-06-16 10:23:08 EDT
There's a small sub-issue which I've logged upstream with a patch, but otherwise in general I don't see a need to implement the complicated multi-selection cell mechanism which would be required to provide the functionality which is tied to the missing selection mode in the statusbar when the selection includes table cells.
Comment 8 RHEL Product and Program Management 2009-06-16 10:38:14 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.