Bug 505005 - dmraid always creates error mapping for the last device in an isw RAID5 set
dmraid always creates error mapping for the last device in an isw RAID5 set
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dmraid (Show other bugs)
5.4
All Linux
high Severity high
: beta
: ---
Assigned To: Heinz Mauelshagen
Corey Marthaler
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 06:55 EDT by Heinz Mauelshagen
Modified: 2009-09-02 07:16 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:16:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heinz Mauelshagen 2009-06-10 06:55:09 EDT
Description of problem:

In case of a RAID5 device failure (isw metadata), dmraid always creates and error mapping for the last device in the set, no matter which one actually failed.

This causes data corruption!

Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc13-46.el5


How reproducible:
Always

Steps to Reproduce:
1. Set RAID device != last one offline
2. dmraid -tay
3. Check for error mapping being created for last device
  
Actual results:
Error mapping created for the wrong device in mapping table.

Expected results:
Error mapping created for the correct (i.e. the failed) device.

Additional info:
Comment 8 Dean Jansa 2009-06-23 11:20:30 EDT
Due to lack of HW we would appreciate feedback from Partner
Comment 9 Chris Ward 2009-07-03 14:45:33 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 10 Chris Ward 2009-07-10 15:14:15 EDT
~~ Attention Partners - RHEL 5.4 Snapshot 1 Released! ~~

RHEL 5.4 Snapshot 1 has been released on partners.redhat.com. If you have already reported your test results, you can safely ignore this request. Otherwise, please notice that there should be a fix available now that addresses this particular request. Please test and report back your results here, at your earliest convenience. The RHEL 5.4 exception freeze is quickly approaching.

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Do not flip the bug status to VERIFIED. Instead, please set your Partner ID in the Verified field above if you have successfully verified the resolution of this issue. 

Further questions can be directed to your Red Hat Partner Manager or other appropriate customer representative.
Comment 12 errata-xmlrpc 2009-09-02 07:16:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1347.html

Note You need to log in before you can comment on or make changes to this bug.