This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 505130 - xfce4-datetime-plugin desktop file in wrong place
xfce4-datetime-plugin desktop file in wrong place
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xfce4-datetime-plugin (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 14:39 EDT by Kevin Fenzi
Modified: 2009-06-10 15:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 15:06:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2009-06-10 14:39:41 EDT
/usr/lib64/xfce4/panel-plugins/datetime.desktop should be 
/usr/share/xfce4/panel-plugins/datetime.desktop
Comment 1 Christoph Wickert 2009-06-10 15:06:01 EDT
Sorry, but the file cannot be in %{_datadir}/xfce4/panel-plugins since it contains an arch specific path:

  X-XFCE-Module=datetime
  X-XFCE-Module-Path=/usr/lib64/xfce4/panel-plugins

Because of the multilib issues we patched it to %{_libdir}/xfce4/panel-plugins and this was *your* idea, remember? ;)

This is something that needs to be fixed upstream because it's a design issue with all external panel plugins. I already mentioned that while talking to Nick Schermer at FOSEDM this year in passing, but he did not see the problem.
Comment 2 Kevin Fenzi 2009-06-10 15:20:51 EDT
Duh. This is what I get for doing about 5 things at once and offering to quickly file a bug for a #fedora user without thinking. ;) 

At least it was a quick bug to fix. ;)

Note You need to log in before you can comment on or make changes to this bug.