Bug 505144 - s390x installer selinux error
s390x installer selinux error
Status: CLOSED DUPLICATE of bug 498611
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
:
Depends On:
Blocks: 456985 457079
  Show dependency treegraph
 
Reported: 2009-06-10 15:50 EDT by wes hayutin
Modified: 2009-08-21 08:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 04:36:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-10 15:50:22 EDT
Description of problem:

s390x rhel 5 6/5.1 build remote db

durring the install got

type=AVC msg=audit(1244662828.498:184): avc:  denied  { execute } for  pid=5235 comm="httpd" name="satidmap.pl" dev=dm-0 ino=618416 scontext=root:system_r:httpd_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file
type=AVC msg=audit(1244663065.018:210): avc:  denied  { execute } for  pid=6839 comm="httpd" name="satidmap.pl" dev=dm-0 ino=618416 scontext=root:system_r:httpd_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file
Comment 1 wes hayutin 2009-06-10 15:51:29 EDT
[root@rhndev5 packages]# /usr/sbin/rhn-satellite status
jabberd router (pid 6261) is running...
osa-dispatcher (pid 6283) is running...
/etc/init.d/tomcat5 is already running (6814)
httpd dead but subsys locked
rhn-search is running (6882).
cobblerd (pid 6917) is running...
RHN Taskomatic is not running.
[root@rhndev5 packages]#
Comment 2 wes hayutin 2009-06-10 15:52:39 EDT
turn selinux to permissive... restart... all ok
Comment 3 wes hayutin 2009-06-10 16:10:21 EDT
so basically this prevents httpd from coming up
Comment 4 Miroslav Suchý 2009-06-11 04:36:44 EDT
This is the same problem as described in
https://bugzilla.redhat.com/show_bug.cgi?id=498611#c5

*** This bug has been marked as a duplicate of bug 498611 ***
Comment 5 Petr Sklenar 2009-08-21 08:46:22 EDT
install part on s390x pass without any avc deny
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=85959

+ it is real duplicate of 498611 
adding ClosedValid to qa whiteboard

Note You need to log in before you can comment on or make changes to this bug.