Bug 505188 - rhel 2.1 provisioning doesn't work with Sat 5.3
rhel 2.1 provisioning doesn't work with Sat 5.3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-06-10 18:20 EDT by Justin Sherrill
Modified: 2009-09-10 15:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:26:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2009-06-10 18:20:07 EDT
Currently with the Sat5.3 code, 2.1 provisioning does not work for a number of reasons:

-spacewalk-koan doesn't install (bad requires)
-koan doesn't run 

we've built new packages to fix the above, but even with those:

- after picking up the action, koan fails saying 'rhnpl' isn't installed, so it can't autodetect the profile (the system record wasnt' being created correctly)

after fixing that:

- during the kickstart the system downloads the kickstart file, but then fails to download the netstg1.img file


this problem was related with having:

url --url http://server:80/ty/a893j

the port number was causing issues.  The reason the port # was there, was because we were using the cobbler variable @@http_server@@ and not $http_server
Comment 1 Justin Sherrill 2009-06-10 18:24:46 EDT
fixed! d47ae3f

rhel 2.1 should provision now.
Comment 2 Steve Salevan 2009-07-13 12:31:21 EDT
RHEL 2.1 provisions successfully.  Moving to VERIFIED, tested on 7/7 build.
Comment 4 Steve Salevan 2009-08-17 16:06:41 EDT
RELEASE_PENDING from latest Stage build.

As per cperry and mmccune's decision, we no longer support kickstarting to 2.1 via Satellite 530, though we do support kickstarting from 2.1 to newer versions of RHEL.
Comment 5 Brandon Perkins 2009-09-10 15:26:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.