Bug 505190 - glusterfs-client package is broken
glusterfs-client package is broken
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: glusterfs (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
: 505389 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 18:32 EDT by Martin Ebourne
Modified: 2009-06-15 21:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.1-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:49:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Ebourne 2009-06-10 18:32:57 EDT
Description of problem:
The glusterfs-client package is completely broken. It installs glusterfs-common which has at least this broken symlink:

lrwxrwxrwx. 1 root root 10 2009-06-10 22:56 /usr/sbin/glusterfs -> glusterfsd

In order to make it work I had to install the glusterfs-server package (which doesn't really make much sense), there was no dependency on this even.

The glusterfs client config file is actually in the server package:
/etc/glusterfs/glusterfs.vol

Version-Release number of selected component (if applicable):
glusterfs-client-2.0.0-0.2.rc7.fc11.x86_64
glusterfs-server-2.0.0-0.2.rc7.fc11.x86_64
glusterfs-common-2.0.0-0.2.rc7.fc11.x86_64
Comment 1 Matthias Saou 2009-06-11 06:52:51 EDT
This had already been fixed in CVS, and I really thought that the packages which were going to be the "final" Fedora ones were fixed, but I seem to have missed that. See bug #501581 for the current status of the 2.0.1 update.
Comment 2 Fedora Update System 2009-06-11 08:39:30 EDT
glusterfs-2.0.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/glusterfs-2.0.1-2.fc11
Comment 3 Matthias Saou 2009-06-12 04:53:59 EDT
*** Bug 505389 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2009-06-15 21:49:38 EDT
glusterfs-2.0.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.