Bug 505225 - GDM logs in with the default language when selecting "last language"
GDM logs in with the default language when selecting "last language"
Status: CLOSED DUPLICATE of bug 505221
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gdm (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 01:00 EDT by Qunfang Zhang
Modified: 2009-06-11 10:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 10:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2009-06-11 01:00:00 EDT
Description of problem:
If you choose "last language" from the language menu on the login screen, gdm
always uses the default language but not the last language.


Version-Release number of selected component (if applicable):
gdm-2.16.0-56.el5

How reproducible:
Always

Steps to Reproduce:
1. Log in using a non default language and select "Just for this session"
2. Log out
3. Log in selecting "last language" from the language menu

  
Actual results:You get the default language


Expected results:You get the same language as the last log in.


Additional info:
Comment 1 Mark Xie 2009-06-11 09:06:04 EDT
Surely the issue exists, I've meet it, too.

The reminding message and the words in the button can confuse the user, it's better changing the words in the reminder box.

For example, now the system default language is en_US, and the session default language is en_US too, if the user changed the language to en_UK in the greeting page, the pop-up dialogue box shows as fallowing:

     Title:
          "Do you wish to make English(UK)(British English) the default for future session?"

     Message:
          You have chosen English(UK) (British English) for this session, but your default setting is System Default.

     Buttons:
          Just For This Session
          Cancel
          Make Default

But the Language chose label shows "Last" and "System Default", these words will confuse the user if they are not clear about system default language and X default language. My understanding is 'Session' is more professional than 'time', and maybe confuse the user. And, the words 'last' and 'default', we just need only one.
Let's take ourself as a completely new user of Linux, and think over the scene when we changed these reminding words and sentences as fallowing:
     Title:
          "Do you wish to make en_UK (British English) the default for Desktop Environment?"

     Message:
          You have chosen en_UK (British English) for your Desktop Environment, but the now default language of your Desktop Environment is en_US (U.S. English). Do you wish to make en_UK (British English) the default?

     Buttons:
          Just For This Time
          Cancel
          Make to Desktop Default

And the Language chose label shows "Desktop Default (en_US)" and "System Default (en_US)"
Comment 2 Ray Strode [halfline] 2009-06-11 10:38:55 EDT

*** This bug has been marked as a duplicate of bug 505221 ***

Note You need to log in before you can comment on or make changes to this bug.