Bug 505247 - FEAT: activate software supend in kernel-PAE
FEAT: activate software supend in kernel-PAE
Status: CLOSED DUPLICATE of bug 456132
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On: 215396
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 03:19 EDT by John Lau
Modified: 2013-01-10 03:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 215396
Environment:
Last Closed: 2011-02-21 15:03:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Lau 2009-06-11 03:19:12 EDT
+++ This bug was initially created as a clone of Bug #215396 +++

Description of problem:

No software suspend on RHEL5 PAE kernel too. Can this feature be added to new version of RHEL5?

I tried the same patch on 2.6.18-128.1.10.el5PAE and it can apply successfully. And I test the kernel and it can have suspend to disk with PAE kernel.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1.
$ cd /boot  
$ diff config-2.6.18-1.2798.fc6 config-2.6.18-1.2798.fc6PAE 
3,4c3,4
< # Linux kernel version: 2.6.18-1.2798.fc6
< # Mon Oct 16 14:34:53 2006
---
> # Linux kernel version: 2.6.18-1.2798.fc6PAE
> # Mon Oct 16 14:51:42 2006
190,191c190,191
< CONFIG_HIGHMEM4G=y
< # CONFIG_HIGHMEM64G is not set
---
> # CONFIG_HIGHMEM4G is not set
> CONFIG_HIGHMEM64G=y
193a194,195
> CONFIG_X86_PAE=y
> # CONFIG_NUMA is not set
229,230d230
< CONFIG_SOFTWARE_SUSPEND=y
< CONFIG_PM_STD_PARTITION=""
1368a1369
> CONFIG_I2O_EXT_ADAPTEC_DMA64=y
3333,3336d3333
< 
< #
< # Page alloc debug is incompatible with Software Suspend on i386
< #

Actual results:
[...]
229,230d230
< CONFIG_SOFTWARE_SUSPEND=y
< CONFIG_PM_STD_PARTITION=""
[...]

Expected results:

No difference in the activation of software suspend since it is not mentioned in 
http://fedora.redhat.com/docs/release-notes/fc6/en_US/sn-Kernel.html#id2840748

Additional info:

For notebook users pae may not be imported but the No eXecute feature and the
suspend feature of the kernel are. For this reason both features should be
accessable or at least it should be proper documented.

--- Additional comment from davej@redhat.com on 2006-11-24 22:19:16 EDT ---

PAE & suspend are incompatible in 2.6.18.  I believe this has been fixed for
2.6.19, so when I backport that after its release, this should be fixed hopefully.

--- Additional comment from mishu@piatafinanciara.ro on 2007-01-12 07:04:29 EDT ---

Situation is the same in kernel-PAE-2.6.19-1.2895.fc6 from updates-testing:
software suspend is disabled. Any reason for not activate it?

--- Additional comment from ncunning@redhat.com on 2007-02-20 16:56:12 EDT ---

As far as I know, swsusp still doesn't support PAE at 2.6.20.

--- Additional comment from fedora@leemhuis.info on 2007-03-02 02:04:43 EDT ---

(In reply to comment #3)
> As far as I know, swsusp still doesn't support PAE at 2.6.20.

2.6.20 should support it afaics:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=2d4a34c9365c6e3f94a5b26ce296e1fce9b66c8b


--- Additional comment from davej@redhat.com on 2007-03-19 16:45:10 EDT ---

Indeed, it should be present in the current builds..

configs/kernel-2.6.20-i686-PAE.config:CONFIG_SOFTWARE_SUSPEND=y


--- Additional comment from opensource@till.name on 2007-03-19 16:55:42 EDT ---

(In reply to comment #5)
> Indeed, it should be present in the current builds..
> 
> configs/kernel-2.6.20-i686-PAE.config:CONFIG_SOFTWARE_SUSPEND=y

$ uname -r; ls /sys/power/
2.6.20-1.2925.fc6PAE
disk  image_size  resume  stat

Yes, this bug is resolved. :-D
Comment 4 Matthew Garrett 2011-02-21 15:03:49 EST

*** This bug has been marked as a duplicate of bug 456132 ***

Note You need to log in before you can comment on or make changes to this bug.