Bug 505273 - Nautilus help crash
Nautilus help crash
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
11
i686 Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 539474 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 05:53 EDT by Alessandro Nazzani
Modified: 2009-11-23 13:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 00:31:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash log (429.17 KB, text/plain)
2009-06-11 05:53 EDT, Alessandro Nazzani
no flags Details
Backtrace (26.65 KB, text/plain)
2009-06-11 11:20 EDT, Alessandro Nazzani
no flags Details
Stacktrace (6.08 KB, text/plain)
2009-06-12 06:49 EDT, Alessandro Nazzani
no flags Details
Stacktrace 2 (16.56 KB, text/plain)
2009-06-12 10:28 EDT, Alessandro Nazzani
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 530589 None None None Never

  None (edit)
Description Alessandro Nazzani 2009-06-11 05:53:51 EDT
Created attachment 347366 [details]
Crash log

Description of problem:

Nautilus help crashed

Version-Release number of selected component (if applicable):

2.26.3

How reproducible:

Always

Steps to Reproduce:
1. Open Nautilus help
2. Search for "side pane" (without quotes)
3. Click on the first result (Keyboard Accessibility Monitor Manual)
  
Actual results:

Window apparently hangs: mouse cursor indicates some activity but nothing seems to happen until I click a second time on the link. At this point I get a crash report (see attachment).

Expected results:


Additional info:
Comment 1 Tomáš Bžatek 2009-06-11 09:04:46 EDT
Can you please either grab bug-buddy output or manually grab the backtrace? https://fedoraproject.org/wiki/StackTraces

Reassigning to yelp, common gnome help viewer. Also, please post an address which document crashes the help viewer (before clicking on the "Keyboard Accessibility Monitor Manual" or such link, right click and select "Copy Link Address").

Nautilus' manual should be part of the Gnome Desktop User Guide

Please post version of your 'yelp' and 'xulrunner' packages
Comment 2 Alessandro Nazzani 2009-06-11 11:20:50 EDT
Created attachment 347422 [details]
Backtrace
Comment 3 Alessandro Nazzani 2009-06-11 11:21:37 EDT
I'm fairly new to gdb, so I hope I did it correctly:

1) issued command "gdb yelp"
2) run
3) reproduced the problem (no crash log this time)
4) saved the terminal output (see attachment)

> please post an address which document crashes the help viewer

file:///usr/share/gnome/help/accessx-status/C/accessx-status.xml#gosnautilus-27

> Please post version of your 'yelp' and 'xulrunner' packages

$ yum list yelp
Loaded plugins: refresh-packagekit
Installed Packages
yelp.i586       2.26.0-3.fc11  installed

$ yum list xulrunner
Loaded plugins: refresh-packagekit
Installed Packages
xulrunner.i586  1.9.1-0.20.beta4.fc11 installed

HTH.

Alessandro
Comment 4 Tomáš Bžatek 2009-06-12 06:09:36 EDT
The process exited with SIGABRT, however it should be possible to grab backtrace anyway, showing the place where it failed.

To get stacktrace, use these steps: https://fedoraproject.org/wiki/StackTraces#Obtaining_a_stack_trace_using_just_GDB
Comment 5 Alessandro Nazzani 2009-06-12 06:49:32 EDT
Created attachment 347534 [details]
Stacktrace
Comment 6 Alessandro Nazzani 2009-06-12 06:50:45 EDT
My bad, apologies.

The 3rd attachment is the snippet of the final part of the session.
Comment 7 Tomáš Bžatek 2009-06-12 08:08:30 EDT
Good, now please install all required debuginfo packages according to https://fedoraproject.org/wiki/StackTraces#What_is_debugging_symbols.2C_and_why_are_they_important.3F

You should see gdb reporting something like
Missing separate debuginfo for /usr/lib/librarian.so.0
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/41/11dac6cd104d86a74791addc7f3b7f8690e204.debug
Comment 8 Alessandro Nazzani 2009-06-12 09:12:52 EDT
Oh my! Are you saying I have to run ALL the "Try: yum --enablerepo..." lines I find in the stacktrace?

That's quite a lot of work (100, maybe more): any way to automate it somehow?
Comment 9 Alessandro Nazzani 2009-06-12 09:19:21 EDT
Never mind: script working right now... :)
Comment 10 Alessandro Nazzani 2009-06-12 10:28:51 EDT
Created attachment 347575 [details]
Stacktrace 2
Comment 11 Alessandro Nazzani 2009-06-12 10:29:58 EDT
Full session stacktrace uploaded after debuginfo packages installation.

Regards.
Comment 12 Tomáš Bžatek 2009-06-12 11:55:59 EDT
Good work! Thank you for the trace, now yelp developers should have enough information to fix this bug.
Comment 13 Matthew Barnes 2009-06-29 00:31:07 EDT
An identical bug has been reported upstream, so I'll refer you there.
Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=530589
Comment 14 Matěj Cepl 2009-11-23 13:26:16 EST
*** Bug 539474 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.