Bug 505306 - Gnote crashes after deleting a note
Gnote crashes after deleting a note
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnote (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 08:50 EDT by Matthias Runge
Modified: 2013-03-13 01:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.5.0-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 04:53:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2009-06-11 08:50:49 EDT
Description of problem:
_Sometimes_ gnote crashes after creating and (nearly immediately) deleting a note.

Version-Release number of selected component (if applicable):
gnote-0.4.0-1.fc11.i586

How reproducible:
40-60%

Steps to Reproduce:
1. Start gnote
2. select "Start Here"
3. select Text and press "Link"
4. delete linked page via trashcan. 
  
Actual results:
crash

Expected results:
no crash

Additional info:

Distribution: Fedora release 11 (Leonidas)
Gnome Release: 2.26.2 2009-06-01 (Red Hat, Inc)
BugBuddy Version: 2.26.0

System: Linux 2.6.29.4-167.fc11.i586 #1 SMP Wed May 27 17:14:37 EDT 2009 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10601901
Selinux: No
Accessibility: Disabled
GTK+ Theme: Nodoka
Icon Theme: Fedora
GTK+ Modules: canberra-gtk-module, pk-gtk-module, gnomebreakpad

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0



---- Critical and fatal warnings logged during execution ----

** glibmm **: 
unhandled exception (type std::exception) in signal handler:
what: 
 


----------- .xsession-errors ---------------------
(gnote:18190): libtomboy-WARNING **: Binding '<Alt>F11' failed!
(gnote:18728): libtomboy-WARNING **: Binding '<Alt>F12' failed!
(gnote:18728): libtomboy-WARNING **: Binding '<Alt>F11' failed!
glibmm-ERROR **: 
unhandled exception (type std::exception) in signal handler:
what: 
aborting...
--------------------------------------------------
Comment 1 Rahul Sundaram 2009-06-11 08:58:45 EDT
Again, can you get me a stack trace on this as well? Thanks
Comment 2 Matthias Runge 2009-06-11 10:27:11 EDT
Trying to reproduce the crash. Seems gone, since installing gnote-debuginfo
Comment 3 Fedora Update System 2009-06-17 03:47:51 EDT
gnote-0.5.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnote-0.5.0-1.fc11
Comment 4 Rahul Sundaram 2009-06-17 03:54:30 EDT
Matthias Runge,

I have marked this bug as among those being fixed in the latest update since I know upstream has fixed a few of them but in case you still see the problem after testing the latest update, do let me know or reopen the bug at a later time.
Comment 5 Matthias Runge 2009-06-17 04:36:59 EDT
Rahul,

thank you. This bug was very tricky to reproduce; I think, we should close this bug.
Comment 6 Fedora Update System 2009-06-24 15:29:06 EDT
gnote-0.5.0-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.