Bug 505309 - cron is off its chum again
cron is off its chum again
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 08:58 EDT by Tom Horsley
Modified: 2009-06-18 08:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 08:06:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cron log (7.47 KB, text/plain)
2009-06-11 09:00 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2009-06-11 08:58:12 EDT
Description of problem:

I'm sitting here configuring my newly genned fedora 11 desktop and I see
makewhatis running. That's typical on a relatively new system. It finishes,
and then a little later, I see makewhatis running yet again. Looking
in the cron logs, I see this for the weekly jobs:

Jun 10 10:01:01 tomh anacron[2445]: Will run job `cron.weekly' in 42 min.
Jun 10 10:43:01 tomh anacron[2445]: Job `cron.weekly' started
Jun 10 10:43:01 tomh run-parts(/etc/cron.weekly)[25753]: starting makewhatis.cron
Jun 11 08:01:05 tomh anacron[6398]: Will run job `cron.weekly' in 42 min.
Jun 11 08:43:05 tomh anacron[6398]: Job `cron.weekly' started
Jun 11 08:43:05 tomh run-parts(/etc/cron.weekly)[15344]: starting makewhatis.cron

I don't know much, but I'm absolutely sure that Jun 11th hasn't been a week
since Jun 10th.

I also see this for makewhatis:

Jun 11 08:23:10 tomh run-parts(/etc/cron.daily)[6687]: starting makewhatis.cron
Jun 11 08:30:02 tomh run-parts(/etc/cron.daily)[12887]: finished makewhatis.cron
Jun 11 08:43:05 tomh run-parts(/etc/cron.weekly)[15344]: starting makewhatis.cron


Version-Release number of selected component (if applicable):
cronie-1.2-7.fc11.x86_64
anacron-2.3-74.fc11.x86_64


How reproducible:
No idea.

Steps to Reproduce:
1.Let system run, observe strange behavior
2.
3.
  
Actual results:


Expected results:


Additional info:

I always find the anacron behaviour uttely counterproductive. If I just
do a yum erase anacron, with cron work properly without it?
Comment 1 Tom Horsley 2009-06-11 09:00:02 EDT
Created attachment 347395 [details]
cron log

I might as well attach the whole cron log, it hasn't gotten very big yet.
Comment 2 Marcela Mašláňová 2009-06-11 09:25:23 EDT
Hello,
makewhatis is at first run by cron.daily and then by cron.weekly. This is strange behaviour of makewhatis, which will be changed in new version. You can't blame cron for this issue.
Best regards,
Marcela
Comment 3 Tom Horsley 2009-06-11 09:37:10 EDT
What about the two cron.weekly runs in two days?
Comment 4 Marcela Mašláňová 2009-06-11 09:52:16 EDT
Ok, that's a problem. It works for me. Does it make a time stamp in /var/spool/anacron/cron.weekly ? Does cron.weekly run every day on your machine?
Comment 5 Tom Horsley 2009-06-11 10:31:57 EDT
I won't know if it runs every day till tomorrow :-).

Perhaps I rebooted it yesterday before weekly got finished and it
therefore decided it needed to start from scratch again?

Things like this are why I always disable the anacron service, but
now I see it isn't a separate service, which is why I wondered if
I could erase the anacron package in order to disable the "helpful"
anacron behavior?

Here's the timestamp I have today:

[root@tomh ~]# ls -l /var/spool/anacron/cron.weekly
-rw------- 1 root root 9 Jun 11 08:49 /var/spool/anacron/cron.weekly
[root@tomh ~]# cat /var/spool/anacron/cron.weekly
20090611
Comment 6 Marcela Mašláňová 2009-06-18 08:06:25 EDT
(In reply to comment #5)
> I won't know if it runs every day till tomorrow :-).
> 
> Perhaps I rebooted it yesterday before weekly got finished and it
> therefore decided it needed to start from scratch again?
Yes, that could be only reason. If the job didn't finish and created time stamp, then it'll start again.

Note You need to log in before you can comment on or make changes to this bug.