Bug 505310 - qpidd: "libibverbs: Fatal: couldn't read uverbs ABI version."
qpidd: "libibverbs: Fatal: couldn't read uverbs ABI version."
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1.1
All Linux
low Severity low
: 1.3
: ---
Assigned To: messaging-bugs
Jiri Kolar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 09:05 EDT by Jiri Kolar
Modified: 2009-10-26 14:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 14:31:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kolar 2009-06-11 09:05:43 EDT
Description of problem:
during qpidd startup "libibverbs: Fatal: couldn't read uverbs ABI version."
is written to log file.

Version-Release number of selected component (if applicable):
> qmf-0.5.752581-15.el5
> qmf-devel-0.5.752581-15.el5
> qpidc-0.5.752581-15.el5
> qpidc-debuginfo-0.5.752581-15.el5
> qpidc-devel-0.5.752581-15.el5
> qpidc-perftest-0.5.752581-15.el5
> qpidc-rdma-0.5.752581-15.el5
> qpidc-ssl-0.5.752581-15.el5
> qpidd-0.5.752581-15.el5
> qpidd-acl-0.5.752581-15.el5
> qpidd-cluster-0.5.752581-15.el5
> qpidd-devel-0.5.752581-15.el5
> qpid-dotnet-0.4.738274-2.el5
> qpidd-rdma-0.5.752581-15.el5
> qpidd-ssl-0.5.752581-15.el5
> qpidd-xml-0.5.752581-15.el5
> qpid-java-client-0.5.751061-7.el5
> qpid-java-common-0.5.751061-7.el5

How reproducible:
Always on RHEL5 only

Steps to Reproduce:
1.run test /distribution/MRG_Messaging/qpid_cpp_client_load_bz456991
 qpidd --auth no -t
2. see common_transcript.log
  
Actual results:
error is written in log file

Expected results:
error should not appear

Additional info:
appears on RHEL5
https://rhts.redhat.com/testlogs/64410/209534/1725513/common_transcript.log

does NOT appear on RHEL4
Comment 1 Andrew Stitcher 2009-06-12 10:20:15 EDT
This message isn't printed by qpid at all it is printed by libibverbs.

In fact it's arguably not a bug at all - not in qpid anyway.

What the message is telling you (some what obscurely) is that you've started the rdma (Infiniband/iWarp) protocol module, but there are no user level drivers for any rdma devices installed.

This is likely a bug in libibverbs in that it outputs directly to stderr.

Note You need to log in before you can comment on or make changes to this bug.