Bug 505329 - libguestfs 'make check' should never hang
libguestfs 'make check' should never hang
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 10:17 EDT by Richard W.M. Jones
Modified: 2010-05-12 08:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-12 08:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-06-11 10:17:32 EDT
If 'make check' fails, it sometimes hangs (because the
underlying qemu process also hangs under many different
circumstances).

Instead, 'make check' should fail after a suitable timeout.

Possibly a simple way to implement this would be to add
alarm (LARGE_NUMBER) to tests.c.  'tests.c' is the first
test which runs, and so is the one which is likely to
hang.
Comment 2 Fedora Update System 2009-06-23 05:15:06 EDT
libguestfs-1.0.51-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.51-1.fc11
Comment 3 Fedora Update System 2009-06-29 15:27:46 EDT
libguestfs-1.0.54-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.54-2.fc11
Comment 4 Fedora Update System 2009-07-02 19:26:33 EDT
libguestfs-1.0.55-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.55-1.fc11
Comment 5 Fedora Update System 2009-07-11 05:27:31 EDT
libguestfs-1.0.58-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.58-2.fc11
Comment 6 Fedora Update System 2009-07-11 13:12:53 EDT
libguestfs-1.0.54-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-07-19 06:28:09 EDT
libguestfs-1.0.58-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Richard W.M. Jones 2010-03-27 06:24:56 EDT
I'm embarrassed to say that this bug has reappeared
because of code movements that we've made.
Comment 9 Richard W.M. Jones 2010-03-27 06:50:53 EDT
Fixed (again) upstream here:

http://git.annexia.org/?p=libguestfs.git;a=commitdiff;h=ef3a6692412b234a46326d330943556977f7c988
Comment 10 Fedora Update System 2010-04-09 10:10:22 EDT
libguestfs-1.2.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.1-1.fc13
Comment 11 Fedora Update System 2010-04-13 03:43:55 EDT
libguestfs-1.2.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.2-1.fc13
Comment 12 Fedora Update System 2010-04-30 19:47:04 EDT
libguestfs-1.2.2-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.