Bug 505336 - registration after kickstart fails for 2.1 machines
registration after kickstart fails for 2.1 machines
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-06-11 10:37 EDT by Justin Sherrill
Modified: 2009-09-10 15:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:26:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2009-06-11 10:37:01 EDT
register a box
kickstart it using a 2.1 kickstart profile


registration in the %post section will fail:

We are out of serverUrl's to try. We tried:
https://columbia.devel.redhat.com/XMLRPC
Traceback (innermost last):
  File "/usr/sbin/rhnreg_ks", line 328, in ?
    main()
  File "/usr/sbin/rhnreg_ks", line 297, in main
    profileName = profilename)
  File "/usr/share/rhn/register/rhnreg.py", line 685, in registerSystem
    auth_dict)
  File "/usr/share/rhn/register/rhnreg.py", line 173, in doCall
    ret = apply(method, args)
  File "/usr/lib/python1.5/site-packages/rhn/_internal_xmlrpclib.py", line 984, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/register/rhnreg.py", line 409, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python1.5/site-packages/rhn/rpclib.py", line 308, in _request
    verbose=self._verbose
  File "/usr/lib/python1.5/site-packages/rhn/transports.py", line 168, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python1.5/site-packages/rhn/transports.py", line 695, in send_http
    headers=self.headers)
  File "/usr/lib/python1.5/site-packages/rhn/_httplib.py", line 549, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib/python1.5/site-packages/rhn/_httplib.py", line 565, in _send_request
    self.putrequest(method, url)
  File "/usr/lib/python1.5/site-packages/rhn/_httplib.py", line 465, in putrequest
    self.send(str)
  File "/usr/lib/python1.5/site-packages/rhn/_httplib.py", line 419, in send
    self.sock.send(str)
  File "/usr/lib/python1.5/site-packages/rhn/SSL.py", line 205, in write
    sent = self._connection.send(data)
SSL.Error: [('SSL routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed')]
ERROR: unable to read system id.




It looks like the sslCACert option isn't being updated in /etc/sysconfig/rhn/up2date.  Even though the option in /etc/sysconfig/rhn/rhn_register is being updated,registration still fails
Comment 1 Justin Sherrill 2009-06-11 10:45:28 EDT
this will probably fix the issue:

perl -npe 's/RHNS-CA-CERT/RHN-ORG-TRUSTED-SSL-CERT/g' -i /etc/sysconfig/rhn/*
Comment 4 Steve Salevan 2009-07-13 12:32:33 EDT
VERIFIED on 7/7 build.
Comment 5 Steve Salevan 2009-08-17 15:55:50 EDT
RELEASE_PENDING from latest Stage build.

As per cperry and mmccune's decision, we no longer support kickstarting to 2.1 via Satellite 530, though we do support kickstarting from 2.1 to newer versions of RHEL.
Comment 6 Brandon Perkins 2009-09-10 15:26:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.