This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 505362 - Errata search, advanced errata search by package name is not returning results
Errata search, advanced errata search by package name is not returning results
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: John Matthews
wes hayutin
https://grandprix.rhndev.redhat.com/r...
: Regression
Depends On:
Blocks: 456985 457073
  Show dependency treegraph
 
Reported: 2009-06-11 12:14 EDT by wes hayutin
Modified: 2009-09-10 15:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:32:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-11 12:14:22 EDT
Description of problem:

6/5.1 rhel 5

1. confirm that there are errata that contain the pkg kernel
2. errata, advanced search, by package name, search for kernel

no results found..

expected results:

erratum listed that have the pkg kernel
Comment 2 John Matthews 2009-06-11 12:59:49 EDT
This is fixed with the below commit.

commit 40bbd72aca5584d24bccea315ccf60d270e7bfee
Author: John Matthews <jmatthew@redhat.com>
Date:   Wed Jun 10 16:04:12 2009 -0400


The issue was that in 6/5.1 ISO I changed the query to flesh out Errata to filter based on org_id, I didn't handle org_id being NULL For Red Hat channels, so I dropped all of those results from the query....this wasn't picked up during testing since I had clones of all the rhel channels I ended up testing with cloned errata.



--- a/java/code/src/com/redhat/rhn/domain/errata/impl/PublishedErrata.hbm.xml
+++ b/java/code/src/com/redhat/rhn/domain/errata/impl/PublishedErrata.hbm.xml
@@ -155,12 +155,16 @@ PUBLIC "-//Hibernate/Hibernate Mapping DTD 3.0//EN"
                    from rhnErrata e,
                         rhnErrataPackage ep,
                         rhnPackage p,
-                        rhnPackageName pn
+                        rhnPackageName pn,
+                        rhnAvailableChannels ac,
+                        rhnChannelErrata ce
                   where e.id = ep.errata_id
                     and p.id = ep.package_id
                     and p.name_id = pn.id
                     and ep.package_id IN (:pids)
-                    and e.org_id IN (:org_ids)
+                    and e.id = ce.errata_id
+                    and ce.channel_id = ac.channel_id
+                    and ac.org_id = :org_id
                   order by e.id]]>
         <return-scalar column="id" type="long" />
         <return-scalar column="advisory" type="string" />
Comment 3 wes hayutin 2009-06-15 14:18:10 EDT
verified 6/12
Comment 4 Preethi Thomas 2009-08-04 14:08:29 EDT
Release Pending
test1182.test.redhat.com
Comment 5 Brandon Perkins 2009-09-10 15:32:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.