Bug 505399 - printer properties crash
Summary: printer properties crash
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 11
Hardware: i686 Linux
low
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 506964 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-06-11 18:49 UTC by smarts40
Modified: 2009-07-22 22:07 UTC (History)
3 users (show)

Fixed In Version: 1.1.8-6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 22:07:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to catch more possible errors when calling this parse (333 bytes, patch)
2009-06-11 18:49 UTC, smarts40
no flags Details | Diff

Description smarts40 2009-06-11 18:49:55 UTC
Created attachment 347453 [details]
patch to catch more possible errors when calling this parse

Description of problem:
Clicking properties on the right click menu of my printer does nothing.

Version-Release number of selected component (if applicable):
Whatever came with fedora 11...

How reproducible:
Install a networked hp laserjet 9050 with "HP LaserJet 9050 Postscript (recommended)" driver via system-config-printer.py.  Then I right clicked on the printer and clicked properties on the pop-up menu.

Steps to Reproduce:
1.  Install networked hp laserjet 9050 with recommended driver
2.  right click on new printer icon in front end
3.  click properties in pop up menu
  
Actual results:
A traceback was generated but otherwise nothing happened.

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 3118, in on_edit_activate
    self.dests_iconview_item_activated (self.dests_iconview, paths[0])
  File "/usr/share/system-config-printer/system-config-printer.py", line 975, in dests_iconview_item_activated
    self.fillPrinterTab (name)
  File "/usr/share/system-config-printer/system-config-printer.py", line 2438, in fillPrinterTab
    self.updateMarkerLevels()
  File "/usr/share/system-config-printer/system-config-printer.py", line 2514, in updateMarkerLevels
    inklevel = gtkinklevel.GtkInkLevel (color, level)
  File "/usr/share/system-config-printer/gtkinklevel.py", line 29, in __init__
    self._color = gtk.gdk.color_parse (color)
TypeError: color_parse() argument 1 must be string, not None


Expected results:
A new window with properties of my printer.

Additional info:
Attached is a patch that seems to fix this for me.  There was already a try statement there, I just added to the except statement, seems to work for me with no error now.

Comment 1 Art Werschulz 2009-06-15 19:53:24 UTC
Same problem occurred with HP Laserjet 4250.

Comment 2 Tim Waugh 2009-06-17 17:00:09 UTC
Fixed upstream.

Comment 3 Art Werschulz 2009-06-18 16:36:13 UTC
When will the fix appear in an update RPM?

Comment 4 Fedora Update System 2009-06-18 17:02:55 UTC
system-config-printer-1.1.8-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/system-config-printer-1.1.8-1.fc11

Comment 5 Art Werschulz 2009-06-18 17:21:20 UTC
While we're at it ...

I noticed that system-config-printer hangs when printing a test (or self-test) page.  I'm eventually told that it's not responding (actually, that '' is not responding) and asked if I want to kill the job.

Oddly enough, "Properties" has started working.

(BTW, should this be a separate bug report?)

Comment 6 Tim Waugh 2009-06-18 17:54:10 UTC
(In reply to comment #5)
> (BTW, should this be a separate bug report?)  

Yes please.

Comment 7 Fedora Update System 2009-06-19 13:46:25 UTC
system-config-printer-1.1.8-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6777

Comment 8 Tim Waugh 2009-06-19 16:15:20 UTC
*** Bug 506964 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2009-06-30 21:23:28 UTC
system-config-printer-1.1.8-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6777

Comment 10 Fedora Update System 2009-07-11 17:10:18 UTC
system-config-printer-1.1.8-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2009-07-20 09:24:02 UTC
system-config-printer-1.1.8-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/system-config-printer-1.1.8-6.fc11

Comment 12 Fedora Update System 2009-07-22 22:06:18 UTC
system-config-printer-1.1.8-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.