Bug 505415 - Can't install RHEL 5.3 variant (i386) on F11 (x86_64) machine [lvcreate failed for Root]
Can't install RHEL 5.3 variant (i386) on F11 (x86_64) machine [lvcreate faile...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 16:15 EDT by Benjamin Kahn
Modified: 2009-06-12 11:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 11:48:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Virt Manager Log (275.70 KB, text/plain)
2009-06-12 10:30 EDT, Benjamin Kahn
no flags Details
QEMU log (1.56 KB, text/plain)
2009-06-12 10:32 EDT, Benjamin Kahn
no flags Details

  None (edit)
Comment 1 Mark McLoughlin 2009-06-12 03:21:39 EDT
Pasting non-private description:

Description of problem:
Can't install RHEL 5.3 variant (i386) on F11 (x86_64) machine [lvcreate failed for Root]

Version-Release number of selected component (if applicable):
qemu-0.10.50-6.kvm86.fc11
qemu-kvm-tools-0.10.50-6.kvm86.fc11
qemu-system-mips-0.10.50-6.kvm86.fc11
qemu-kvm-0.10.50-6.kvm86.fc11
libvirt-python-0.6.4-2.fc11
qemu-system-sparc-0.10.50-6.kvm86.fc11
qemu-system-arm-0.10.50-6.kvm86.fc11
qemu-system-sh4-0.10.50-6.kvm86.fc11
qemu-system-m68k-0.10.50-6.kvm86.fc11
qemu-user-0.10.50-6.kvm86.fc11
qemu-system-ppc-0.10.50-6.kvm86.fc11
qemu-system-cris-0.10.50-6.kvm86.fc11
qemu-system-x86-0.10.50-6.kvm86.fc11
libvirt-0.6.4-2.fc11
qemu-img-0.10.50-6.kvm86.fc11
qemu-common-0.10.50-6.kvm86.fc11

How reproducible:
100% on this machine

Steps to Reproduce:
1. download RHEL5.3 variant ISO
2. Set up a new virtual machine booting from the iso
3. After package dep resolution, I get the error: lvcreate failed for Root

Actual results:
LVM operation failed
lvcreate failed for Root
The installer will now exit
[ Reboot ]

Expected results:
Install works.  :)
Comment 2 Mark McLoughlin 2009-06-12 03:21:55 EDT
Setting version to rawhide, since these are packages from the virt-preview repository.
Comment 3 Mark McLoughlin 2009-06-12 03:26:49 EDT
Assuming you used virt-manager, please include ~/.virt-manager/virt-manager.log. If you're not using virt-manager, please include the guest XML config

Also, include the guest log file from /var/log/libvirt/qemu

It'd be good to get a hold of the anaconda log files - e.g. switch to the shell on tty2 and scp the logfiles of the guest

Could you try downgrading to qemu-0.10.5-2.fc11 to see if that works? i.e. is it just a regression in rawhide?

See also https://fedoraproject.org/wiki/Reporting_virtualization_bugs
Comment 6 Mark McLoughlin 2009-06-12 06:21:35 EDT
Apparently this was originally seen with the F-11 versions, moving back to F-11
Comment 7 Benjamin Kahn 2009-06-12 10:30:31 EDT
Created attachment 347576 [details]
Virt Manager Log

several attempts to install F11 and RHEL 5.3 variant

None of the installs worked, but the RHEL 5.3 installs always failed at the lvcreate step.
Comment 8 Benjamin Kahn 2009-06-12 10:32:11 EDT
Created attachment 347577 [details]
QEMU log
Comment 9 Justin M. Forbes 2009-06-12 11:48:01 EDT
It appears that this particular image uses a kickstart which lays out more than 8GB of file systems.  The default in virt-manager is 8GB so the lvcreate fails because there is not enough space available.  Increase disk size and it will work fine.

Note You need to log in before you can comment on or make changes to this bug.