Bug 505463 - supertuxkart-0.6.1-2.fc11.i586 fails to install with archive unpack error
supertuxkart-0.6.1-2.fc11.i586 fails to install with archive unpack error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: supertuxkart (Show other bugs)
11
i586 Linux
low Severity low
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 20:27 EDT by Jamie Anderson
Modified: 2009-07-22 17:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.6.1a-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 17:52:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Anderson 2009-06-11 20:27:14 EDT
Description of problem:

[jamie@klooger ~]$ sudo yum upgrade
Loaded plugins: dellsysidplugin2, downloadonly, priorities, refresh-packagekit
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package supertuxkart.i586 0:0.6.1-2.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================
 Package                                  Arch                             Version                                  Repository                          Size
=============================================================================================================================================================
Updating:
 supertuxkart                             i586                             0.6.1-2.fc11                             fedora                             101 M

Transaction Summary
=============================================================================================================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 101 M
Is this ok [y/N]: y
Downloading Packages:
supertuxkart-0.6.1-2.fc11.i586.rpm                                                                                                    | 101 MB     02:19     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : supertuxkart                                                                                                                          1/2 
Error unpacking rpm package supertuxkart-0.6.1-2.fc11.i586
error: unpacking of archive failed on file /usr/share/supertuxkart/data/po: cpio: rename

Failed:
  supertuxkart.i586 0:0.6.1-2.fc11                                                                                                                           

Complete!


Version-Release number of selected component (if applicable):
0:0.6.1-2.fc11

How reproducible:


Steps to Reproduce:
1. attempt to install/upgrade supertuxkart-0.6.1-2.fc11.i586
2.
3.
  
Actual results:
package is not installed or updated

Expected results:
package is installed or updated 

Additional info:
I tried rebuilding the srpm with the same results.
Comment 1 Gwyn Ciesla 2009-06-15 08:26:11 EDT
To be clear, is this the F-11 rpm on F-11, or the F-11 rpm on an earlier release?
Comment 2 Jamie Anderson 2009-06-15 08:51:55 EDT
F11 RPM on F11. If it matters, I upgraded F10 via DVD and then used 'yum upgrade' to get the remaining updates.
Comment 3 Gwyn Ciesla 2009-06-15 09:19:36 EDT
How'd that go?  I upgrade via yum, and am awaiting the next push to solve some dependency issues.  Does package-cleanup --problems (from yum-utils) give you anything?
Comment 4 Jamie Anderson 2009-06-15 10:46:58 EDT
It wasn't pretty. I track the games spin, so I had a lot of extra stuff to pull in after the fact. I used the DVD so I could run the torrent for a few days and give something back, but next time I will probably just use preupgrade. :)

package-cleanup --problems was clean, btw.
Comment 5 Gwyn Ciesla 2009-06-15 10:59:27 EDT
Interesting.  I'll take a peek once I have an F-11 machine, should be very shortly after the impending push.
Comment 6 Gwyn Ciesla 2009-06-16 11:36:59 EDT
Just successfully yum upgraded, and yum install supertuxkart was fine. 

Not that it's usable:

https://bugzilla.redhat.com/show_bug.cgi?id=506245

But that's another story.

Can you yum clean all ; yum install supertuxkart?
Comment 7 Jamie Anderson 2009-06-16 23:01:34 EDT
Same error.
Comment 8 Gwyn Ciesla 2009-06-17 08:01:22 EDT
Ah-ha!  My install in #6 was a fresh install.  Upgrading reproduced exactly your error.  My guess is a dir/symlink issue.  I'll take a peek at this today.
Comment 9 Gwyn Ciesla 2009-06-17 14:50:00 EDT
Yeah, that's what it is.  I can put a fix together, just went through this with gallery2. <shudder>
Comment 10 Gwyn Ciesla 2009-06-18 11:39:11 EDT
FYI, I've got this worked out, I'm just not going to bother building it until 506245 is out.  Unless you'd like it to play with to help with that bug? :)
Comment 11 Marco Atzeri 2009-07-04 11:43:34 EDT
same problem on x86_64

Error unpacking rpm package supertuxkart-0.6.1-2.fc11.x86_64
error: unpacking of archive failed on file /usr/share/supertuxkart/data/po: cpio: rename
 
$ uname -a
Linux enterprise.atzeri.it 2.6.29.5-191.fc11.x86_64 #1 SMP Tue Jun 16 23:23:21 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

also this system is an upgrade from previous fedora
Comment 12 Fedora Update System 2009-07-06 08:57:56 EDT
supertuxkart-0.6.1a-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/supertuxkart-0.6.1a-1.fc11
Comment 13 Marco Atzeri 2009-07-10 13:07:32 EDT
unpacking problem solved, 
thanks Marco
Comment 14 Fedora Update System 2009-07-11 12:54:26 EDT
supertuxkart-0.6.1a-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update supertuxkart'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7422
Comment 15 Fedora Update System 2009-07-22 17:52:50 EDT
supertuxkart-0.6.1a-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.