Bug 50547 - Cannot umount a reiserfs file system that I am using for Squid.
Cannot umount a reiserfs file system that I am using for Squid.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-31 23:14 EDT by Andrig T. Miller
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version: 2.11g
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 19:48:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrig T. Miller 2001-07-31 23:14:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010701

Description of problem:
If I shutdown my system, the system hangs while "Unmounting local file
systems".  I narrowed down this problem, by stopping Squid (service squid
stop), and trying to umount /webcache (the mount point for my reiserfs file
sytem that Squid is using).  The umount command simply hangs, and cannot be
killed.  I believe this problem was introduced with an update to the mount
package, because this was not happening with my initial implementation of
reiserfs on RedHat 7.1.  The umount -V command reports the following
version information:

umount: mount-2.11b

How reproducible:
Always

Steps to Reproduce:
1.mount any reiserfs file system
2.umount any reiserfs file system
3.
	

Actual Results:  umount hangs, and cannot be killed.

Expected Results:  umount should finish, and the file system should no
longer be mounted.

Additional info:

I believe this issue was introduced with a patch to mount.  The umount -V
command reports the following version information:

umount: mount-2.11b
Comment 1 john.l.villalovos 2001-08-02 12:12:38 EDT
Did you upgrade your kernel?  If so this is probably a duplicate of bug 45628.
Comment 2 Andrig T. Miller 2001-08-02 19:51:54 EDT
I looked at bug 45628, and it does appear to be the same problem, because I did
upgrade to the 2.4.3-12 kernel.
Comment 3 Andrig T. Miller 2002-01-24 22:43:24 EST
This problem has been fixed, and I have since upgraded my system to RedHat 7.2,
where the problem is also no longer occuring.  You can close this bug.

Note You need to log in before you can comment on or make changes to this bug.