Bug 505525 - How to update from rawhide of last week to 11 of now using yum?
How to update from rawhide of last week to 11 of now using yum?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 04:47 EDT by Donald Cohen
Modified: 2014-01-21 18:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 20:05:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Cohen 2009-06-12 04:47:54 EDT
Description of problem:
I'm having trouble understanding or following the directions for changing
from rawhide (which was 11 when I last did an update) to 11 now that it's supposed to be released.
http://fedoraproject.org/wiki/YumUpgradeFaq#Fedora_10_-.3E_Fedora_11_.28tentative.29
says

rpm -Uhv ftp://download.fedora.redhat.com/pub/fedora/linux/releases/<ReleaseNumber>/Fedora/<Arch>/os/Packages/fedora-release-*.noarch.rpm

This gives me errors.
Perhaps the problem is in the repository?  Or the web page above?
On mirrors the versions of that file I see come from May, so must not be intended for moving to 11 release since at that time 11 was rawhide.

Right now if I do yum update I get offered a bunch of fc12's, which makes sense since rawhide is now 12.
I expected that by doing the rpm above I'd install something like
 /etc/yum.repos/fedora.repo-11

Perhaps I should just try to fake a version by copying -10 ?
Comment 1 Christopher Beland 2009-06-12 20:05:17 EDT
You might just need to disable the Rawhide repositories /etc/yum.repos.d/ and enable the regular Fedora ones.  The Yum Upgrade FAQ page doesn't really cover upgrading from Rawhide.  I added a link to http://fedoraproject.org/wiki/Upgrading_from_pre-release_to_final which you may find helpful.  If this doesn't work, I recommend asking for help on fedora-test-list; see http://www.redhat.com/mailman/listinfo/fedora-test-list for subscription info.  If you continue to get errors while following the instructions, please include them in your email (in case there really is a bug somewhere).

Since I don't believe this is a yum bug, I'm closing this report.  Good luck with your upgrade!
Comment 2 Donald Cohen 2009-06-14 15:35:44 EDT
(In reply to comment #1)
> You might just need to disable the Rawhide repositories /etc/yum.repos.d/ and
> enable the regular Fedora ones.  
I've now done this.  See below.
  The Yum Upgrade FAQ page doesn't really cover
> upgrading from Rawhide.  I added a link to
> http://fedoraproject.org/wiki/Upgrading_from_pre-release_to_final which you may
> find helpful. 
This seems to be specific to rawhide=>12 in that it describes things that don't
seem to apply to 11.
 
> Since I don't believe this is a yum bug, I'm closing this report.
I send the following here, since it seems that the original summary still applies.
When I do yum update I now get a bunch of fc11 packages listed, but it ends as follows:

  --> Finished Dependency Resolution
  classpathx-jaf-1.0-14.3.fc11.x86_64 from updates has depsolving problems
    --> Missing Dependency: libgcj_bc.so.1()(64bit) is needed by package classpathx-jaf-1.0-14.3.fc11.x86_64 (updates)
  jetty-5.1.15-4.fc11.x86_64 from updates has depsolving problems
    --> Missing Dependency: libgcj_bc.so.1()(64bit) is needed by package jetty-5.1.15-4.fc11.x86_64 (updates)
  Error: Missing Dependency: libgcj_bc.so.1()(64bit) is needed by package jetty-5.1.15-4.fc11.x86_64 (updates)
  Error: Missing Dependency: libgcj_bc.so.1()(64bit) is needed by package classpathx-jaf-1.0-14.3.fc11.x86_64 (updates)
   You could try using --skip-broken to work around the problem
   You could try running: package-cleanup --problems
                          package-cleanup --dupes
                          rpm -Va --nofiles --nodigest
This seems somewhat surprising since
$ locate libgcj_bc
/usr/lib/gcc/x86_64-redhat-linux/4.4.0/libgcj_bc.so
/usr/lib/gcc/x86_64-redhat-linux/4.4.0/32/libgcj_bc.so
/usr/lib64/libgcj_bc.so.1
/usr/lib64/libgcj_bc.so.1.0.0
/usr/lib64/libgcj_bc.so.1;4a29da1e
and
$ ls -l /usr/lib64/libgcj_bc.so*
lrwxrwxrwx. 1 root root   23 2009-06-08 09:03 /usr/lib64/libgcj_bc.so.1 -> libgcj_bc.so.1;4a29da1e
-rwxr-xr-x. 1 root root 2888 2008-11-05 04:18 /usr/lib64/libgcj_bc.so.1.0.0
lrwxrwxrwx. 1 root root   18 2009-06-05 20:14 /usr/lib64/libgcj_bc.so.1;4a29da1e -> libgcj_bc.so.1.0.0
[2009-06-14 19:31:58 root@number11 ~]

I'm not sure what I'm supposed to get out of this:

$ package-cleanup --problems
Setting up yum
Loaded plugins: dellsysidplugin2, fastestmirror
Loading mirror speeds from cached hostfile
Reading local RPM database
Processing all local requires
Missing dependencies:
Package jakarta-commons-pool requires libgcj_bc.so.1()(64bit)
Package ant requires libgcj_bc.so.1()(64bit)
Package xml-commons-apis requires libgcj_bc.so.1()(64bit)
Package lucene-contrib requires libgcj_bc.so.1()(64bit)
Package bcel requires libgcj_bc.so.1()(64bit)
Package lucene requires libgcj_bc.so.1()(64bit)
Package bsf requires libgcj_bc.so.1()(64bit)
Package log4j requires libgcj_bc.so.1()(64bit)
Package ant-commons-logging requires libgcj_bc.so.1()(64bit)
Package ant-apache-oro requires libgcj_bc.so.1()(64bit)
Package classpathx-jaf requires libgcj_bc.so.1()(64bit)
Package jakarta-commons-logging requires libgcj_bc.so.1()(64bit)
Package jakarta-commons-digester requires libgcj_bc.so.1()(64bit)
Package ant-apache-bsf requires libgcj_bc.so.1()(64bit)
Package axis requires libgcj_bc.so.1()(64bit)
Package xpdf requires poppler-utils
Package gcc-java requires libgcj = 4.4.0-4
Package gcc-java requires libgcj-tools.so.10()(64bit)
Package gcc-java requires libgcj.so.10()(64bit)
Package gcc-java requires libgcj_bc.so.1()(64bit)
Package gcc-java requires libgij.so.10()(64bit)
Package jakarta-commons-httpclient requires libgcj_bc.so.1()(64bit)
Package junit4 requires libgcj_bc.so.1()(64bit)
Package xalan-j2 requires libgcj_bc.so.1()(64bit)
Package regexp requires libgcj_bc.so.1()(64bit)
Package ant-apache-log4j requires libgcj_bc.so.1()(64bit)
Package hamcrest requires libgcj_bc.so.1()(64bit)
Package java-1.5.0-gcj-devel requires /usr/bin/gij
Package ant-swing requires libgcj_bc.so.1()(64bit)
Package jakarta-commons-el requires libgcj_bc.so.1()(64bit)
Package mx4j requires libgcj_bc.so.1()(64bit)
Package sinjdoc requires libgcj >= 4.1.2
Package sinjdoc requires libgcj_bc.so.1()(64bit)
Package jdom requires libgcj_bc.so.1()(64bit)
Package gettext-devel requires libgcj_bc.so.1()(64bit)
Package ecj requires libgcj >= 4.0.0
Package ecj requires libgcj_bc.so.1()(64bit)
Package ant-javamail requires libgcj_bc.so.1()(64bit)
Package libgcj-devel requires libgcj = 4.4.0-4
Package libgcj-devel requires /usr/lib64/libgcj.so.10
Package xerces-j2 requires libgcj_bc.so.1()(64bit)
Package qdox requires libgcj_bc.so.1()(64bit)
Package ant-apache-bcel requires libgcj_bc.so.1()(64bit)
Package ant-junit requires libgcj_bc.so.1()(64bit)
Package jdepend requires libgcj_bc.so.1()(64bit)
Package jakarta-commons-dbcp requires libgcj_bc.so.1()(64bit)
Package xml-commons-resolver requires libgcj_bc.so.1()(64bit)
Package jakarta-commons-modeler requires libgcj_bc.so.1()(64bit)
Package java-1.5.0-gcj requires /usr/bin/gcj-dbtool
Package java-1.5.0-gcj requires /usr/bin/gcj-dbtool
Package java-1.5.0-gcj requires /usr/bin/gij
Package java-1.5.0-gcj requires /usr/bin/gij
Package java-1.5.0-gcj requires /usr/bin/gij
Package java-1.5.0-gcj requires /usr/lib64/security/classpath.security
Package java-1.5.0-gcj requires libgcj >= 4.1.2-5
Package classpathx-mail requires libgcj_bc.so.1()(64bit)
Package ant-antlr requires libgcj_bc.so.1()(64bit)
Package libgcj-src requires libgcj = 4.4.0-4
Package ant-apache-resolver requires libgcj_bc.so.1()(64bit)
Package ant-commons-net requires libgcj_bc.so.1()(64bit)
Package antlr requires libgcj_bc.so.1()(64bit)
Package ant-nodeps requires libgcj_bc.so.1()(64bit)
Package jakarta-commons-discovery requires libgcj_bc.so.1()(64bit)
Package cups requires poppler-utils
Package ant-jsch requires libgcj_bc.so.1()(64bit)
Package ant-apache-regexp requires libgcj_bc.so.1()(64bit)
Package ant-trax requires libgcj_bc.so.1()(64bit)
Package jakarta-commons-collections requires libgcj_bc.so.1()(64bit)
Package jakarta-commons-beanutils requires libgcj_bc.so.1()(64bit)
Package ant-jdepend requires libgcj_bc.so.1()(64bit)
Package junit requires libgcj_bc.so.1()(64bit)
Package jzlib requires libgcj_bc.so.1()(64bit)
Package java_cup requires libgcj_bc.so.1()(64bit)
Package jetty requires libgcj_bc.so.1()(64bit)
Package jakarta-oro requires libgcj_bc.so.1()(64bit)
Package frysk requires libgcj.so.10()(64bit)
Package jakarta-commons-launcher requires libgcj_bc.so.1()(64bit)
Package jakarta-commons-fileupload requires libgcj_bc.so.1()(64bit)
Package wsdl4j requires libgcj_bc.so.1()(64bit)
Comment 3 Donald Cohen 2009-06-14 21:41:04 EDT
I think I have found and fixed my mistake - updating repository files
Assume all is now ok until further notice.

Note You need to log in before you can comment on or make changes to this bug.