Bug 50555 - G++ throws Internal Compiler Error when compiling the latest TAO ORB distro.
G++ throws Internal Compiler Error when compiling the latest TAO ORB distro.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 01:09 EDT by Parag Warudkar
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 13:38:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CPP Source file that causes the error : Watch line 893 (33.19 KB, text/plain)
2001-08-01 01:12 EDT, Parag Warudkar
no flags Details

  None (edit)
Description Parag Warudkar 2001-08-01 01:09:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010701

Description of problem:
G++ Says : Internal compiler error in scan_region at except.c:2809
while compiling the attached file.

How reproducible:
Always

Steps to Reproduce:
1.Get the latest TAO distro from (cs.wustl.edu/~schmidt/)
2.Compile.
3.Watch the error..
	

Actual Results:  Internal compiler error in scan_region at except.c:2809

Expected Results:  Compilation should go thru.

Additional info:

Used these flags :   g++ -march=i686 -W -Wall -Wpointer-arith -pipe -O3 -g
-Wno-uninitialized -fno-implicit-templates   -D_POSIX_THREADS
-D_POSIX_THREAD_SAFE_FUNCTIONS -D_REENTRANT -DACE_HAS_AIO_CALLS 
-I/home/parag/ace  -DACE_HAS_EXCEPTIONS    -I/home/parag/ace/TAO  -c -fPIC

The -march=i686 option doesn't affect the error. Error occurs with and
without it.
Comment 1 Parag Warudkar 2001-08-01 01:12:06 EDT
Created attachment 25712 [details]
CPP Source file that causes the error : Watch line 893
Comment 2 Parag Warudkar 2001-08-01 03:52:43 EDT
g++ -v :
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-94)
Comment 3 Parag Warudkar 2001-08-01 04:33:31 EDT
This macro is the cause of the problem : (If I define ACE_UNUSED_ARG to empty,
g++ compiles fine)

#if defined (ghs) || defined (__GNUC__) || defined (__hpux) || defined (__sgi)
|| defined (__DECCXX) || defined (__KCC) || defined (__rational__) || defined
(__USLC__) || defined (ACE_RM544)
// Some compilers complain about "statement with no effect" with (a).
// This eliminates the warnings, and no code is generated for the null
// conditional statement.  NOTE: that may only be true if -O is enabled,
// such as with GreenHills (ghs) 1.8.8.
# define ACE_UNUSED_ARG(a) do {/* null */} while (&a == 0)
#else /* ghs || __GNUC__ || ..... */
# define ACE_UNUSED_ARG(a) (a)
#endif /* ghs || __GNUC__ || ..... */
Comment 4 Parag Warudkar 2001-08-16 07:24:14 EDT
Is anything happening with this bug?
Comment 5 Jakub Jelinek 2001-08-20 10:56:52 EDT
Please provide preprocessed testcase (e.g. using -save-temps option).
Comment 6 Parag Warudkar 2001-08-20 23:45:30 EDT
Here is a new source file and its preprocessed testcase
The error :ImplRepoS.cpp: In function `void
POA_ImplementationRepository::Administration::server_is_running_skel
(TAO_ServerRequest &, void *, void *, Environment &)':
ImplRepoS.cpp:3526: Internal compiler error in scan_region, at except.c
:2809
Comment 7 Jakub Jelinek 2001-09-06 13:37:57 EDT
As the preprocessed testcase is missing, I cannot tell for sure, but I guess
this is a dupe of #48835 fixed in gcc-c++-2.96-97.
Comment 8 Parag Warudkar 2001-09-07 01:59:25 EDT
Yep. fixed in 2.96-97.

Parag

Note You need to log in before you can comment on or make changes to this bug.