Bug 505600 - rc.sysinit needs addition to /var cleanup to accommodate new libvirt /var/run layout
rc.sysinit needs addition to /var cleanup to accommodate new libvirt /var/run...
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
All Linux
low Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
: Regression
Depends On:
  Show dependency treegraph
Reported: 2009-06-12 10:52 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
7 users (show)

See Also:
Fixed In Version: 8.45.29-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-09-02 07:14:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2009-06-12 10:52:29 EDT
Description of problem:
libvirt-0.6.3-8.el5 now includes /var/run/libvirt/network and 
/var/run/libvirt/qemu so the /var cleanup script rc.sysinit needs to be extended to accommodate the additional directory depth, otherwise the user gets messages on boot about not being able to remove the files because they are directories.

--- rc.sysinit.orig     2009-06-12 10:45:58.000000000 -0400
+++ rc.sysinit  2009-06-12 10:48:22.000000000 -0400
@@ -864,6 +864,7 @@
                */cvs)          rm -rf $afile/* ;;
                */dovecot)      rm -f $afile/*/* ;;
                */cups)         rm -f $afile/*/* ;;
+               */libvirt)      rm -rf $afile/*/* ;;
                *)              rm -f $afile/* ;;

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot up a 5.4 system
Actual results:
Message about being unable to remove /var/run/libvirt/network and /var/run/libvirt/qemu because they are directories.

Expected results:
Removal of the run files.

Additional info:
This is a behavioral regression introduced by new libvirt code.  5.3 didn't have the same problem because the /var/run/libvirt/{network,qemu} directories didn't exist in the 5.3 libvirt.
Comment 3 Jay Turner 2009-06-16 10:28:48 EDT
Fix confirmed with initscripts-8.45.29-1.el5.x86_64.  Will move to Verified once the package appears in an RCM tree.
Comment 4 Chris Ward 2009-07-03 14:45:48 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 5 Jay Turner 2009-07-06 08:37:28 EDT
initscripts-8.45.29-1.el5 is included in the 20090701initscripts-8.45.29-1.el5.0 trees.  Moving to Verified.
Comment 8 errata-xmlrpc 2009-09-02 07:14:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.