This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 505648 - PCI MSI breaks ESATA (ahci)
PCI MSI breaks ESATA (ahci)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 14:25 EDT by drago01
Modified: 2009-09-28 03:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-28 03:33:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errors in dmesg (11.41 KB, text/plain)
2009-06-12 14:25 EDT, drago01
no flags Details

  None (edit)
Description drago01 2009-06-12 14:25:04 EDT
Description of problem:
After upgrading to F11 (where pci msi is enabled by default). ESATA no longer works (disk does not show up).

Disabling MSI by passing "pci=nomsi" to the kernel fixes that.

Version-Release number of selected component (if applicable):

kernel-2.6.29.4-167.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. boot
2. plug in a ESATA drive
3. fail
  
Actual results:

It fails to detect the drive.

Expected results:

Disk should work.
Comment 1 drago01 2009-06-12 14:25:35 EDT
Created attachment 347643 [details]
Errors in dmesg
Comment 2 Paul Lambert 2009-07-15 23:26:26 EDT
When adding a an eSata PCI device to my vm configuration (SB700/SB800 Sata Controller AHCI Mode) receive this error:  Kernel; journal commit I/O error.  This immediately delets the vm machine from the virt-manager and locks up the host.  To return to normal a hard, power off, reset is necessary.  There is no way a guest configuration should shutdown the host.

In inspecting the output of mount, I found my eSata disk mounts to the Fedora host at /dev/sdb1.  I then went into vm configuration and added a storage disk for this device and seleted SCSI type.  With the eSata disk plugged in at vm startup the vm Windows machine saw this disk and installed the driver automatically.  I repeated this process only this time selecting IDE disk and it also worked via the eSata connection.

I believe the eSata devices should be plug and play just like USB.  If so, how are is eSata to be configured or is this work in progress?

dv7-1230us, Fedora standard release with updates as of 7/13.  No testing updates.
Comment 3 drago01 2009-09-28 03:33:03 EDT
(In reply to comment #0)
> Description of problem:
> After upgrading to F11 (where pci msi is enabled by default). ESATA no longer
> works (disk does not show up).
> 
> Disabling MSI by passing "pci=nomsi" to the kernel fixes that.
> 
> Version-Release number of selected component (if applicable):
> 
> kernel-2.6.29.4-167.fc11.x86_64
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. boot
> 2. plug in a ESATA drive
> 3. fail
> 
> Actual results:
> 
> It fails to detect the drive.
> 
> Expected results:
> 
> Disk should work.  

I can not reproduce this with 2.6.30 builds. (i.e seems fixed in 2.6.30)

Paul: Your report seems to be a different issue (not related that MSI breaks eSata)

Note You need to log in before you can comment on or make changes to this bug.