Bug 505657 - Lower part of volume slider has no effect on actual volume
Lower part of volume slider has no effect on actual volume
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 507731 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 15:14 EDT by François Kooman
Modified: 2009-10-08 10:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 07:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
area of volume slider that has the same (low) volume (53.02 KB, image/png)
2009-06-12 15:14 EDT, François Kooman
no flags Details
alsa info file (15.64 KB, text/plain)
2009-06-12 15:18 EDT, François Kooman
no flags Details

  None (edit)
Description François Kooman 2009-06-12 15:14:48 EDT
Created attachment 347647 [details]
area of volume slider that has the same (low) volume 

Description of problem:

When changing volume to lower 1/3 of the volume slider (see screenshot) corresponds to one (low) volume.

Version-Release number of selected component (if applicable):

pulseaudio-0.9.15-11.fc11.x86_64
alsa-lib-1.0.20-1.fc11.x86_64
kernel-2.6.29.4-167.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:
1. 
   # alsactl init   

(volume gets restored to default volume, which is a bit loud as a default, but well...)

2. move the volume slider down.
  
Actual results:

Unable to effectively use full range of volume slider. Slider up == very loud, OK. Slider in the lower 1/3 part is the same low volume (between 5-10%). Slider all the way down is mute (totally quiet), OK.

Expected results:

Gradual volume control from top to bottom of slider, maybe a less loud default (-25% of what it is now)

Additional info:

See all attachments as requested by AlsaVolume blocker bug
Comment 1 François Kooman 2009-06-12 15:18:52 EDT
Created attachment 347648 [details]
alsa info file

By the way, this is a HP Compaq 6710b laptop using the internal laptop speakers.
Comment 2 Adam Williamson 2009-06-12 21:07:05 EDT
this isn't actually an AlsaVolume type bug. it's very similar to another report, which has a good explanation from Lennart of what's going on. I'll find it and act appropriately in a minute, hockey just came back on =)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2009-06-12 21:47:01 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=502057 is the one I'm thinking of. Lennart, does this look like the same issue as in that bug, to you?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Lennart Poettering 2009-06-29 07:39:31 EDT
*** Bug 507731 has been marked as a duplicate of this bug. ***
Comment 5 Lennart Poettering 2009-06-29 07:41:04 EDT
PA in Rawhide now uses a different mapping of volume 'percentages' to dB which makes the lower part of the sliders more useful.
Comment 6 Laurent Aguerreche 2009-10-07 18:01:10 EDT
Hi!

I'm sorry to reopen this bug but I still encounter it (since many months and my ears can confirm!). I would like to know if you intend to backport (hopefully soon) the fix present in rawhide to Fedora 11...

Rgds,
Laurent.
Comment 7 Lennart Poettering 2009-10-08 10:35:00 EDT
(In reply to comment #6)
> Hi!
> 
> I'm sorry to reopen this bug but I still encounter it (since many months and my
> ears can confirm!). I would like to know if you intend to backport (hopefully
> soon) the fix present in rawhide to Fedora 11...

No, I don't. This change is more than a bugfix, so I really not convinced that this should be backported.

Note You need to log in before you can comment on or make changes to this bug.