Bug 505700 - ibus - can not use quick or cangjie
ibus - can not use quick or cangjie
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-table (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 500973
  Show dependency treegraph
 
Reported: 2009-06-12 20:25 EDT by Steven Drinnan
Modified: 2009-06-28 19:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.1.0.20090610-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:38:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Drinnan 2009-06-12 20:25:58 EDT
Description of problem:
Using install of F11 64bit, Added Changjie input method. Added Quick 5. But when it try and select it ibus does nothing.

Version-Release number of selected component (if applicable):
1.1.0.20090309-6


How reproducible:
Always
Just add quick 5 or 3 or any other in this component.

Steps to Reproduce:
1. Click on Ibus icon in task bar
2. Select quick 5
3.
  
Actual results:

Nothing at all

Expected results:

Selected input method should work.


Additional info:

None

Anything I can do back trace etc - but you need to tell me what to do.

Steven
Comment 1 Caius Chance 2009-06-14 19:15:15 EDT
Defect is confirmed. Fix is pending.

I am working on same problem on F-10. F-11 will be processed shortly.
Comment 2 Fedora Update System 2009-06-16 00:24:00 EDT
ibus-table-1.1.0.20090610-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ibus-table-1.1.0.20090610-1.fc11
Comment 3 Fedora Update System 2009-06-18 07:44:19 EDT
ibus-table-1.1.0.20090610-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-table'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6565
Comment 4 Fedora Update System 2009-06-24 15:38:41 EDT
ibus-table-1.1.0.20090610-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Steven Drinnan 2009-06-24 20:21:04 EDT
Sorry I misunderstood,

The problem is not completely fixed, the tables load but are unusable as the characters are not displayed properly. All fonts are installed and this problem is not apprent when using SCIM.

I made a note like you said at this site http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6565  but i guess no one reads it.

IBUS sucks
Comment 6 Caius Chance 2009-06-26 02:30:23 EDT
Hi, 

(In reply to comment #5)
> The problem is not completely fixed, the tables load but are unusable as the
> characters are not displayed properly. 

This is the candidate sorting problem which is another problem. It is a bug from upstream release tarball and I am still yet to patch it. I am filing another bug ticket in regard to that.

Precisely, the tables is not unstable but has 'dynamic sorting' which it will adjust the order during learning the usage frequency on characters along time. So 'hp pgdn 8' may not map to εΎ³ because the order is keep updated in every input of 'hp' key. At this stage there is no GUI way to turn this off. Before the GUI switch is available, it needs to be done by flag off the dynamic order in table source and rebuild the table manually.

Also, for those characters that were not displayed properly on your computer, they are actually real character w/o corresponded glyphs of font on the system. I agreed those characters are 'less used' ones and should be at the bottom of the candidate list. I will keep communicate to upstream developer about this.

All fonts are installed and this problem
> is not apprent when using SCIM.

SCIM actually contains much less range of characters than IBus.

> I made a note like you said at this site
> http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6565  but i guess no one
> reads it.

I have read that and replied a while ago.

> IBUS sucks  

I do think IBus might not be a superset to SCIM at this stage, though IBus is more advanced on some aspects. IBus actually are not the source of the unhappiness you mentioned, IBus-Table instead.

I encourage you to use SCIM now, if you prefer an older but more reliable (currently) technology. It is not difficult to install SCIM via yum and switch SCIM as default by 'im-chooser'.

Thank you very much for your valuable information.
Comment 7 Steven Drinnan 2009-06-26 06:16:07 EDT
No it is not that it is unusable because you can not read the characters. It is like the font is not installed. 

It just shows a square box.

That's the problem you can not use an input method when you can not read the characters.
Comment 8 Caius Chance 2009-06-28 19:28:17 EDT
(In reply to comment #7)
> No it is not that it is unusable because you can not read the characters. It is
> like the font is not installed. 

It exactly is the font is not installed for those characters.

> It just shows a square box.

The square boxes are square boxes are expected. In fact, characters as square boxes be allocated at front locations of candidate list is incorrect.

This problem has been resolved in zh_CN and zh_TW, but yet in all other locales. I need arrange resources to test the latest upstream (author) release source pack before I intro to F11. Also, it will take some time for public testing to ensure the latest release is usable.

If you need urgent usage on critical system, you could downgrade ibus-table to 1.1.0.20090316 or temporary switch to SCIM.

Thank you very much.

Note You need to log in before you can comment on or make changes to this bug.