Bug 505729 - Please remove /usr/share/texmf dir ownership in gnuplot-common
Please remove /usr/share/texmf dir ownership in gnuplot-common
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnuplot (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 05:35 EDT by Jindrich Novy
Modified: 2013-07-02 19:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 05:07:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed gnuplot.spec change (2.37 KB, patch)
2009-06-15 04:27 EDT, Jindrich Novy
no flags Details | Diff
Proposed gnuplot.spec change with fixed directory ownership. (2.41 KB, patch)
2009-06-15 04:30 EDT, Jindrich Novy
no flags Details | Diff

  None (edit)
Description Jindrich Novy 2009-06-13 05:35:56 EDT
Description of problem:
gnuplot-common owns /usr/share/texmf directory what is bad. It should be owned by TeX Live packages where the proper ownership has to be fixed. The problem is that if the ownership is fixedon TeX Live side it then conflicts with gnuplot.

How reproducible:
always

Steps to Reproduce:
$ rpm -qf /usr/share/texmf
gnuplot-common-4.2.4-6.fc11.x86_64
Comment 1 Patrice Dumas 2009-06-13 14:00:47 EDT
Since when is it impossible to have more than one package own a directory? /usr/share/texmf should be owned by both texlive and gnuplot. If I recall well, gnuplot drops a tex file, and I think it is better to have it own /usr/share/texmf than having a dependency on texlive.
Comment 2 Jindrich Novy 2009-06-15 03:15:58 EDT
(In reply to comment #1)
> Since when is it impossible to have more than one package own a directory?

Since:
Transaction Check Error:
  file /usr/share/texmf from install of texlive-2008-0.1.fc11.x86_64 conflicts with file from package gnuplot-common-4.2.4-6.fc11.x86_64

> /usr/share/texmf should be owned by both texlive and gnuplot. If I recall well,
> gnuplot drops a tex file, and I think it is better to have it own
> /usr/share/texmf than having a dependency on texlive.  

Nope. You don't seems to get the point. In that case every -devel package should own %{_includedir} and similar nonsenses.

A proper solution is to create a subpackage shipping the tex file which depends on TeX. This is actually the only possible non-hackish solution.
Comment 3 Jindrich Novy 2009-06-15 03:19:12 EDT
Ivana, could you please update gnuplot BuildRequires to require tex(latex) instead of tetex-latex? tetex is gone for some time already and the tetex virtual provides are soon to be dropped what could break gnuplot build.

Thanks.
Comment 4 Jindrich Novy 2009-06-15 04:27:34 EDT
Created attachment 347899 [details]
Proposed gnuplot.spec change
Comment 5 Jindrich Novy 2009-06-15 04:30:59 EDT
Created attachment 347900 [details]
Proposed gnuplot.spec change with fixed directory ownership.
Comment 6 Ivana Varekova 2009-06-15 05:07:12 EDT
Thanks fixed in gnuplot-4.2.5-4.fc12 - thanks for the patch.
Comment 7 Patrice Dumas 2009-06-15 06:56:02 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > Since when is it impossible to have more than one package own a directory?
> 
> Since:
> Transaction Check Error:
>   file /usr/share/texmf from install of texlive-2008-0.1.fc11.x86_64 conflicts
> with file from package gnuplot-common-4.2.4-6.fc11.x86_64

That's weird. And a big change. I relied on having directory not conflicting in many of my former packages.

> Nope. You don't seems to get the point. In that case every -devel package
> should own %{_includedir} and similar nonsenses.

That's what the filesystem package is for.

> A proper solution is to create a subpackage shipping the tex file which depends
> on TeX. This is actually the only possible non-hackish solution.  

I disagree. Although this is an acceptable solution, I think that doing a subpackage just for this file is pointless. It could make sense in other packages, but in this one, I don't think this is the right choice, at least not for the directory ownership reason.

Another solution would have been to excerpt from texlive the basic directory structure and have a texlive-filesystem (or better yet a tex(filesystem)) package.

In the end, is is up to Ivana to do the choice.


One point in favor of doing that subpackage is to explicit that some terminals won't work without LaTeX being installed, but this is different from doing it for the directory ownership issue.
Comment 8 Jindrich Novy 2009-06-15 08:36:35 EDT
Patrice,

actually you are very close to the way how the TL2008/9 packaging is done. The main texlive metapackage now contains and owns all of its directories (all dirs of the scheme-full) so it is a filesystem package equivalent. In the current state it contains a dependency on scheme-basic in TL though. This actually helped much to not to leave unowned dirs after TL removal but the directory ownership machinery still needs fixing on RPM side.

Just the fact that all TL directories are now owned by TL itself revealed this directory ownership problem. Given that the gnuplot.cfg shipped in the TEXMF tree is actually unusable without LaTeX it still makes perfectly sense to move it to subpackage and make it dependent on tex(latex) IMO.

Note You need to log in before you can comment on or make changes to this bug.