Bug 505739 - Permissions on /var/run/clamd.scan
Permissions on /var/run/clamd.scan
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 06:49 EDT by Nick P G Smith
Modified: 2009-10-13 21:32 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.95.2-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 21:32:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick P G Smith 2009-06-13 06:49:04 EDT
Description of problem:
Installing the default clam RPMs (0.95.1-2.fc11.i586)

Version-Release number of selected component (if applicable):
0.95.1-2.fc11.i586

How reproducible:
Every time

Steps to Reproduce:
1. Configure sendmail to use milter
2. Configure milter to point to clamd socket /var/run/clamd.scan/clamd.sock
3. Send an incoming email
  
Actual results:
Mail is not deliverd, we get in /var/log/maillog:
Milter: data, reject=451 4.3.2 Please try again later

Expected results:
Mail is delivered

Solution:
The problem is with the permission:
# ls -ld clamd.scan/
drwx--x--- 2 clamscan clamscan 4096 2009-06-13 11:40 clamd.scan/

Things work properly with:
# ls -ld clamd.scan/
drwx--x--x 2 clamscan clamscan 4096 2009-06-13 11:40 clamd.scan/
Comment 1 Fedora Update System 2009-09-13 09:13:45 EDT
clamav-0.95.2-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/clamav-0.95.2-3.fc11
Comment 2 Fedora Update System 2009-09-15 03:43:15 EDT
clamav-0.95.2-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update clamav'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9572
Comment 3 Vadym Chepkov 2009-09-15 17:15:21 EDT
I was fixing it with including clamilt user id into clamscan group.
I think it is more appropriate fix.
Comment 4 Enrico Scholz 2009-09-15 19:29:55 EDT
* Sun Sep 13 2009 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.95.2-3
- add the 'clamilt' user to the 'clamscan' group when the -scanner
  subpackage is installed (#505739)
Comment 5 Vadym Chepkov 2009-09-15 21:23:02 EDT
Great!

Not sure if I need t open another bz or I just miss something about freshclam.
/usr/sbin/clamav-notify-servers relies on /etc/init.d/ scripts, but I use *upstart version instead.
it seems in *-upstart, server is never notified about the update. Am I wrong?
Comment 6 Fedora Update System 2009-10-13 21:32:14 EDT
clamav-0.95.2-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.