Bug 505753 - The application DrPython isnt starting because of a missing directory or file
The application DrPython isnt starting because of a missing directory or file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: drpython (Show other bugs)
11
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Marc Wiriadisastra
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 10:56 EDT by Fabian
Modified: 2009-06-24 15:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.11.0-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:39:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian 2009-06-13 10:56:39 EDT
Description of problem:

DrPython isnt starting. When I try to open it in the bash it tells me:
@localhost ~]$ drpython
/usr/bin/drpython: line 3: /usr/lib/python2.5/site-packages/drpython/drpython.py: No such file or directory

Version-Release number of selected component (if applicable):
Epoch      : 1
Version    : 3.11.0
Release    : 4.fc11

How reproducible:


Steps to Reproduce:
1.install the programm via kpackagekit or yum
2.open a bash and type "drpython" in order to open the programm
3.
  
Actual results:
/usr/bin/drpython: line 3: /usr/lib/python2.5/site-packages/drpython/drpython.py: No such file or directory

Expected results:
The application should start and display the IDE

Additional info:
I'm using Fedora 11 with KDE 4.2
Comment 1 Marc Wiriadisastra 2009-06-13 11:34:37 EDT
Thanks for this it's basically because python2.5 should be python2.6. I'll update the package in the next couple of days but if you want it fixed straight away just edit the /usr/bin/drpython file and change it manually.
Comment 2 Fabian 2009-06-13 12:42:25 EDT
(In reply to comment #1)
> Thanks for this it's basically because python2.5 should be python2.6. I'll
> update the package in the next couple of days but if you want it fixed straight
> away just edit the /usr/bin/drpython file and change it manually.  

Thank you, I did that and it works. It just gives me some deprecation warning like:
/usr/lib/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py:14450: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")
/usr/lib/python2.6/site-packages/drpython/drNotebook.py:93: DeprecationWarning: <function SetSashBorder at 0xa46417c> is deprecated
Comment 3 Marc Wiriadisastra 2009-06-13 19:53:25 EDT
Ignore the deprecation the reason why it shows up is because it hasn't been updated to python 2.6.
Comment 4 Fedora Update System 2009-06-13 22:59:19 EDT
drpython-3.11.0-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/drpython-3.11.0-5.fc11
Comment 5 Fedora Update System 2009-06-15 22:42:41 EDT
drpython-3.11.0-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update drpython'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6475
Comment 6 Fedora Update System 2009-06-24 15:39:42 EDT
drpython-3.11.0-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.