Bug 505771 - RFE: Allow Cache to Expire Also When Offline
RFE: Allow Cache to Expire Also When Offline
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
https://fedorahosted.org/sssd/ticket/60
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 12:45 EDT by Daniel Qarras
Modified: 2009-10-24 08:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-24 08:37:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2009-06-13 12:45:08 EDT
Description of problem:
As per https://www.redhat.com/archives/freeipa-users/2009-June/msg00040.html it might in some cases be useful to allow cached entries to expire also when offline. For example, an organization may have a policy that all users must change they passwords twice a month - in that case it would be non-compliant that a user can keep using his password "forever" if offline.

Additional info:
https://www.redhat.com/archives/freeipa-users/2009-June/msg00040.html
Comment 1 Simo Sorce 2009-06-17 09:11:46 EDT
Ok, here we have 2 separate issues.
one is the user/groups cache, another is the credentials cache (hashed, cached password).

What we need to "expire" are only credential caches.
It should be harmless to keep around user/group caches.
Comment 2 Daniel Qarras 2009-10-24 08:37:14 EDT
Since this is upstreamed at https://fedorahosted.org/sssd/ticket/60 I'll close this one.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.