Bug 505794 - Fedora 11 Locks/Panics/Freezes when Connecting to WPA Wireless Network using NetworkManager
Fedora 11 Locks/Panics/Freezes when Connecting to WPA Wireless Network using ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 18:08 EDT by Derek Hildreth
Modified: 2009-06-25 18:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 18:15:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The wireless network settings I'm using. (37.80 KB, image/png)
2009-06-13 18:08 EDT, Derek Hildreth
no flags Details
/var/log/messages file containing the crash (1.55 MB, text/plain)
2009-06-20 01:18 EDT, Derek Hildreth
no flags Details

  None (edit)
Description Derek Hildreth 2009-06-13 18:08:05 EDT
Created attachment 347781 [details]
The wireless network settings I'm using.

**Description of problem:**

I'm having this problem specifically on a MacBook 5,1 with Fedora 11 installed (I haven't tested on any other system). When I connect to a wireless network with WPA encryption, the system freezes up. I have to hold down the power button to do a hard shutdown. I can connect to an open wireless connection with no problems. I haven't tested WEP encryption.

I've been scouring the internets for any sort of solution and have been unsuccessful. The closest thing I've come to is an Ubuntu bug located here: 
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/336001

I searched on the Red Hat's bugzilla, and this was the closest one I found:
https://bugzilla.redhat.com/show_bug.cgi?id=453298


**Version-Release number of selected component (if applicable):**
====================
rpm -qa |grep Network
====================
NetworkManager-0.7.1-4.git20090414.fc11.i586
NetworkManager-glib-0.7.1-4.git20090414.fc11.i586
NetworkManager-gnome-0.7.1-4.git20090414.fc11.i586


**How reproducible:**
Always.  

**Steps to Reproduce:**
1.  Boot Fedora 11 and Login
2.  Select a WPA encrypted network and enter credentials.

Specifically, these are the steps I took trying to connect to my university's wireless:
1. Select wireless network (in my case BYU-I)
2. Select WPA & WPA2 Enterprise
3. Select PEAP as Authentication
4. Select PEAP Version 0
5. Select MSCHAPv2 for inner authentication
6. Enter credentials
7. Select Ignore for the "No certificate authority certificate chosen" message
8. Try to connect.

  
**Actual results:**
System locks up and freezes.  I'm not sure if this is a kernel panic, but it certainly seems like it.  Mouse locks up, there is no keyboard response to any other commands.

**Expected results:**
Become connected to the wireless network and be able to browse the internet.

**Additional info:**
====================
lspci -v output:
====================
03:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
	Subsystem: Apple Computer Inc. Device 008d
	Physical Slot: 3
	Flags: bus master, fast devsel, latency 0, IRQ 23
	Memory at 93100000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: wl
	Kernel modules: wl


====================
uname -r
====================
2.6.29.4-167.fc11.i686.PAE


====================
rpm -qa |grep wpa
====================
wpa_supplicant-0.6.8-1.fc11.i586

I have also attached an image of my network settings because, well, a picture is worth a thousand words.

Thanks for any assistance with this.  I also have a forum thread on it here:
http://forums.fedoraforum.org/showthread.php?t=223776
Comment 1 Derek Hildreth 2009-06-13 18:13:43 EDT
I just tried it with WPA & WPA2 Personal at home, and it worked just fine.
Comment 2 Niels Haase 2009-06-15 16:48:27 EDT
Thanks for filling this bug.
Can you please provide your /var/log/messages after the problem occurred? Thanks you. I think this is a kernel issues that caused your problem, but with the messages log we say it for sure.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Derek Hildreth 2009-06-20 01:18:10 EDT
Created attachment 348733 [details]
/var/log/messages file containing the crash

Here's the snippit that I thought was important, but the rest has been attached.  The line directly after what you see here was me rebooting again after a hard shutdown:

Jun 19 19:21:49 sphinx NetworkManager: <info>  Activation (eth1) starting connection 'Auto BYUI'
Jun 19 19:21:49 sphinx NetworkManager: <info>  (eth1): device state change: 3 -> 4
Jun 19 19:21:49 sphinx NetworkManager: <info>  Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled...
Jun 19 19:21:49 sphinx NetworkManager: <info>  Activation (eth1) Stage 1 of 5 (Device Prepare) started...
Jun 19 19:21:49 sphinx NetworkManager: <info>  Activation (eth1) Stage 2 of 5 (Device Configure) scheduled...
Jun 19 19:21:49 sphinx NetworkManager: <info>  Activation (eth1) Stage 1 of 5 (Device Prepare) complete.
Jun 19 19:21:49 sphinx NetworkManager: <info>  Activation (eth1) Stage 2 of 5 (Device Configure) starting...
Jun 19 19:21:49 sphinx NetworkManager: <info>  (eth1): device state change: 4 -> 5
Jun 19 19:21:49 sphinx NetworkManager: <info>  Activation (eth1/wireless): connection 'Auto BYUI' has security, and secrets exist.  No new secrets needed.
Jun 19 19:21:49 sphinx NetworkManager: <info>  Config: added 'ssid' value 'BYUI'
Jun 19 19:21:49 sphinx NetworkManager: <info>  Config: added 'scan_ssid' value '1'
Jun 19 19:21:49 sphinx NetworkManager: <info>  Config: added 'key_mgmt' value 'WPA-EAP'
Jun 19 19:21:49 sphinx NetworkManager: <info>  Config: added 'password' value '<omitted>'
Jun 19 19:21:49 sphinx NetworkManager: <info>  Config: added 'eap' value 'PEAP'
Jun 19 19:21:49 sphinx NetworkManager: <info>  Config: added 'fragment_size' value '1300'
Jun 19 19:21:49 sphinx NetworkManager: <info>  Config: added 'phase1' value 'peapver=0'
Jun 19 19:21:49 sphinx NetworkManager: <info>  Config: added 'phase2' value 'auth=MSCHAPV2'
Jun 19 19:21:49 sphinx NetworkManager: <info>  Config: added 'identity' value 'students\hildretd'
Jun 19 19:21:49 sphinx NetworkManager: <info>  Activation (eth1) Stage 2 of 5 (Device Configure) complete.
Jun 19 19:21:49 sphinx NetworkManager: <info>  Config: set interface ap_scan to 1
Jun 19 19:21:49 sphinx NetworkManager: <info>  (eth1): supplicant connection state:  scanning -> disconnected
Jun 19 19:21:51 sphinx NetworkManager: <info>  (eth1): supplicant connection state:  disconnected -> scanning
Comment 4 Derek Hildreth 2009-06-25 18:15:42 EDT
Good news!

After the updates that came through last night, logging into the wireless network no longer locks up the system.

Thanks for all of your help!

Note You need to log in before you can comment on or make changes to this bug.