Bug 505830 - Cells Functions in Status Bar do not Display Correctly in OpenOffice.org
Cells Functions in Status Bar do not Display Correctly in OpenOffice.org
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 03:50 EDT by Mat
Modified: 2013-04-02 00:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 10:26:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upper part of picture shows the bug in Fedora 11, lower part shows how it should be base on rpms from www.openoffice.org (118.95 KB, image/png)
2009-06-14 03:50 EDT, Mat
no flags Details

  None (edit)
Description Mat 2009-06-14 03:50:33 EDT
Created attachment 347806 [details]
Upper part of picture shows the bug in Fedora 11, lower part shows how it should be base on rpms from www.openoffice.org

Description of problem:
One can right-click in the status bar on the cell functions to select different functions. The cell functions in the status bar should include Count, Maximum, Sum, etc. However, they only include "Sum/Average" and "None." 

Version-Release number of selected component (if applicable):
OpenOffice.org 3.1, that is, the one that you get with 
   yum groupinstall "Office/Productivity"
in Fedora 11. 

How reproducible:
Easily reproducible. 

Steps to Reproduce:
1. yum groupinstall "Office/Productivity"
2. start OpenOffice.org
3. right-click on the status bar where the cells functions are 
  
Actual results:
A menu opens that displays "Sum/Average" and "None." See the attachment (upper part of picture). 

Expected results:
A menu opens that displays "Average," "CountA," "Count," "Maximum," "Minimum," "Sum," and "None." See the attachment (lower part of picture). I obtained this attachment by taking a screenshot from installing the rpms from the openoffice.org website. 

Additional info:
I looked for ways to enhance the cells functions menu in the status bar in Fedora 11, but was unable to find anything related. As a consequence, I believe this is a bug because it seems that it cannot be remedied by changing some options.
Comment 1 Caolan McNamara 2009-06-14 05:14:26 EDT
Red Hat reviews and scrubs its code for intellectual property issues. Our
approach has always been conservative, i.e., if there is any question, resolve
the issue or remove the code.  Red Hat recently implemented a number of changes
in its distribution of OpenOffice to address such issues.  These changes should
not be construed as implying any immediate intellectual property problem;
rather, they have been implemented to assure that no such immediate problems
arise. While implementing these changes in our own distribution of OpenOffice,
we have also made them available upstream to the OpenOffice project.
Comment 2 Mat 2009-06-14 10:40:44 EDT
Thanks for the comment. These cells functions are very useful for people who are working with OpenOffice.org for example in finance-related fields. The way I understand the comment from Caolan McNamara is that there are intellectual property issues. 

I'm not a legal expert, but it's difficult to see why including "Sum/Average" is not an issue, and why including "Count" is an issue. Maybe there is a way to reconsider the decision to close this bug.
Comment 4 Bob Miller 2009-12-26 09:21:39 EST
These functions are absolutely essential in the work I (an others) do. Without them, I am forced to revert to the generic openoffice download.

I echo Mat's comment above. It is difficult to see how Count (and CountA) could be part of intellectual property.

Note You need to log in before you can comment on or make changes to this bug.