Bug 505842 - smoltSendProfile doesn't work on Swedish locale
smoltSendProfile doesn't work on Swedish locale
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 05:49 EDT by Fredrik Duprez
Modified: 2009-06-22 16:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 16:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fredrik Duprez 2009-06-14 05:49:24 EDT
Description of problem:

Try to run smoltSendProfile and an error occurs

Version-Release number of selected component (if applicable):

smolt-1.2-4.2.fc11.noarch

How reproducible:

run smoltSendProfile

Steps to Reproduce:
1. smoltSendProfile
2.
3.
  
Actual results:

Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 31, in <module>
    from i18n import _
  File "/usr/share/smolt/client/i18n.py", line 36, in <module>
    t = gettext.translation('smolt', '/usr/share/locale/', fallback = True)
  File "/usr/lib/python2.6/gettext.py", line 480, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib/python2.6/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib/python2.6/gettext.py", line 316, in _parse
    plural = v[1].split('plural=')[1]


Expected results:


Additional info:

It looks like this has been filed against F7-10 as well. Is there a workaround?
Comment 1 Fredrik Duprez 2009-06-14 10:25:20 EDT
Found a workaround:

LANG=en_US.utf8
followed by smoltSendProfile works.

Smolt should behave more gracefully if a translation doesn't exist.

http://www.smolts.org/client/show/pub_df7ce2df-1372-463f-b30d-5d63c2b477ae
Comment 2 Mike McGrath 2009-06-22 16:32:45 EDT
This should be handled a bit better in the next release.

Note You need to log in before you can comment on or make changes to this bug.