Bug 505887 - DeviceTreeError: duplicate paths in device tree
DeviceTreeError: duplicate paths in device tree
Status: CLOSED DUPLICATE of bug 527913
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:bf3ee875ac1bcb84c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 10:52 EDT by bjass57
Modified: 2009-10-08 09:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-17 14:04:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (234.21 KB, text/plain)
2009-06-14 10:52 EDT, bjass57
no flags Details

  None (edit)
Description bjass57 2009-06-14 10:52:07 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 1782, in devices
    raise DeviceTreeError("duplicate paths in device tree")
  File "/usr/lib/anaconda/storage/__init__.py", line 324, in disks
    devices = self.devicetree.devices
  File "/usr/lib/anaconda/storage/partitioning.py", line 555, in doPartitioning
    disks = storage.disks
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1017, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1132, in editPartition
    if self.refresh():
  File "/usr/lib/anaconda/iw/partition_gui.py", line 974, in newCB
    self.editPartition(device, isNew=1)
DeviceTreeError: duplicate paths in device tree
Comment 1 bjass57 2009-06-14 10:52:19 EDT
Created attachment 347825 [details]
Attached traceback automatically from anaconda.
Comment 2 bjass57 2009-06-16 11:25:18 EDT
Bug occurred whilst partitioning Volume Group
Comment 3 David Lehman 2009-07-02 18:56:56 EDT
I know it has been a while, but can you possibly provide a sequence of steps you performed in order to hit this bug?
Comment 4 bjass57 2009-07-23 07:25:06 EDT
All I can remember is I was partitioning installing Fedora 11 and inadvertently tried to install a partition where their wasn't the room, got a notification to that effect, clicked on something else and bingo it went down.
Comment 5 Chris Lumens 2009-10-08 09:27:45 EDT
Duping to a new bug with the same traceback and reproducer information...

*** This bug has been marked as a duplicate of bug 527913 ***

Note You need to log in before you can comment on or make changes to this bug.