Bug 505911 - Intel 3945abg wireless bandwidth
Intel 3945abg wireless bandwidth
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity urgent
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 513462
  Show dependency treegraph
 
Reported: 2009-06-14 12:41 EDT by Matt
Modified: 2010-01-05 06:42 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-05 06:42:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt 2009-06-14 12:41:13 EDT
Description of problem:

bandwith limited to around 1mb/s on intel wireless 3945abg card in fedora 11.

Version-Release number of selected component (if applicable):


How reproducible:

every time

Steps to Reproduce:
1. boot fedora 11 with an intel 3945abc wireless card
2.
3.
  
Actual results:


Expected results:


Additional info:

tested on dell xps m1530 laptop & inspiron 9400 laptop. problem not present in fedora 10/xp triboot on same laptops. 

on intital connection to the wireless network all bandwidth is availble for a few minutes before it gets limited.

issue is present in some versions of other distros maybe something kernel/driver related breaking?
Comment 1 Jim Campbell 2009-08-04 21:34:24 EDT
I have experienced this problem on my thinkpad t60 with the intel 3945 wireless card.  Initially I'm able to access any wireless AP without any problems, but then the connection slows to a trickle for no apparent reason.

Ubuntu Jaunty users with intel wireless cards are reporting a similar problem under this bug ( https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/348204 ) 

I know that there were problems with the intel drivers around the time that Fedora 11 / Ubuntu 9.04 were released. Is there anything that can be done to remedy this on a Fedora 11 system?
Comment 2 Stanislaw Gruszka 2009-09-22 10:00:13 EDT
Hello.

Does problem still reproducible on current F11 kernel (2.6.30 based)? 

What is network configuration: type (a,b,g), encryption ?
Comment 3 Jim Campbell 2009-10-03 01:21:37 EDT
Hi there,

Sorry for the late reply, but I had switched to using Xubuntu because of this bug.  I'm glad to report now, though, that this bug appears to be fixed for me now, thus enabling me to use Fedora for regular tasks.

uname -r
2.6.30.8-64.fc11.i586


iwl3945-firmware v.15.32.2.9 
release 1.fc11

The wireless network is a mixed B/G access point using WPA2 Personal encryption with the TKIP algorithm.  

I hope this helps, but please let me know if you need more info.  Thank you for your work in resolving this bug.
Comment 4 Stanislaw Gruszka 2009-10-05 09:01:39 EDT
(In reply to comment #3)
> I'm glad to report now, though, that this bug appears to be fixed for me
> now, thus enabling me to use Fedora for regular tasks.
[snip]
> I hope this helps, but please let me know if you need more info.  Thank you for
> your work in resolving this bug.  

Sorry, I'm a bit confused. Does this bug needs any additional work ?
Comment 5 Jim Campbell 2009-10-06 22:02:52 EDT
I am no longer experiencing this problem. As far as I am concerned, this bug requires no additional work.  Thanks very much.
Comment 6 Stanislaw Gruszka 2009-10-07 04:45:18 EDT
Matt, 

What about you, did you try to upgrade F11 kernel?
Comment 7 Stanislaw Gruszka 2010-01-05 06:42:24 EST
According to comment 5 I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.