Bug 505916 - Synce-HAL does not work with my device
Synce-HAL does not work with my device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: synce-hal (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 13:17 EDT by Aurelien Bompard
Modified: 2009-06-27 08:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.13.1-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 23:01:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lsusb -v (related entries) (2.79 KB, text/plain)
2009-06-14 13:17 EDT, Aurelien Bompard
no flags Details
Output of lshal -l (related entries) (13.68 KB, text/plain)
2009-06-14 13:18 EDT, Aurelien Bompard
no flags Details

  None (edit)
Description Aurelien Bompard 2009-06-14 13:17:50 EDT
Created attachment 347837 [details]
Output of lsusb -v (related entries)

Description of problem:
It looks like synce-hal does nothing with my device. It's a HTC "Touch Cruise" (Polaris on xda-developers), with Windows Mobile 6.1 on it.
I've added a debug configuration file as found in this thread : https://sourceforge.net/forum/forum.php?thread_id=3092955&forum_id=96106 but I get nothing in the logs. The RNDIS interface is created, but not brought up, and no dhcp client is started. In my process list, I have nothing related to synce.

I'm attaching the output of "lsusb -v" and "lshal -l" (only entries related to this device). Hope it'll help.

That's all I get in /var/log/messages:
kernel: usb 8-1: new full speed USB device using uhci_hcd and address 11
kernel: usb 8-1: New USB device found, idVendor=0bb4, idProduct=0b0d
kernel: usb 8-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
kernel: usb 8-1: Product: Generic RNDIS
kernel: usb 8-1: Manufacturer: HTC
kernel: usb 8-1: SerialNumber: 3fbf5000-7351-0801-3559-800107241060
kernel: usb 8-1: configuration #1 chosen from 1 choice
kernel: rndis_host 8-1:1.0: RNDIS_MSG_QUERY(0x00010202) failed, -47
kernel: eth1 (rndis_host): not using net_device_ops yet
kernel: eth1: register 'rndis_host' at usb-0000:00:1d.2-1, RNDIS device, 80:00:60:0f:e8:00

Please advise how I can help debug this.

Version-Release number of selected component (if applicable):
synce-hal-0.13.1-2.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. Plug the device in
2. Nothing happens
Comment 1 Aurelien Bompard 2009-06-14 13:18:31 EDT
Created attachment 347839 [details]
Output of lshal -l (related entries)
Comment 2 Aurelien Bompard 2009-06-14 15:32:45 EDT
OK, I found the reason: the 'hal-synce-*" commands are installed in /usr/lib/hal, which is the "debian" directory, according to the HAL spec: http://people.freedesktop.org/~david/hal-spec/hal-spec.html#device-properties-info-callouts.
We must install them in /usr/libexec. I just symlinked the two commands to /usr/libexec and the phone connected straight away !

I still can't create a partnership but that's probably another story.

Please fix the path in the RPM.
Comment 3 Fedora Update System 2009-06-14 18:06:20 EDT
synce-hal-0.13.1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/synce-hal-0.13.1-3.fc11
Comment 4 Fedora Update System 2009-06-14 18:07:10 EDT
synce-hal-0.13.1-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/synce-hal-0.13.1-3.fc10
Comment 5 Fedora Update System 2009-06-18 07:53:44 EDT
synce-hal-0.13.1-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update synce-hal'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6634
Comment 6 Fedora Update System 2009-06-18 07:54:51 EDT
synce-hal-0.13.1-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update synce-hal'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6646
Comment 7 Fedora Update System 2009-06-26 23:01:05 EDT
synce-hal-0.13.1-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-06-26 23:02:36 EDT
synce-hal-0.13.1-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Andri Möll 2009-06-27 04:39:20 EDT
Using synce-hal-0.13.1-3.fc11, the new interface gets configured, but is still not working fully:

Jun 27 11:31:21 localhost hal-dccm[23548]: CRITICAL: main: Failed to connect to system bus: An SELinux policy prevents this sender from sending this message to this recipient (rejected message had sender "(unset)" interface "org.freedesktop.DBus" member "Hello" error name "(unset)" destination "org.freedesktop.DBus")

Doesn't seem to be the same error as bug #505931.
Comment 10 Andri Möll 2009-06-27 08:08:24 EDT
I posted bug #508459 concerning these SELinux messages mentioned in comment #9.

Note You need to log in before you can comment on or make changes to this bug.